summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-05-28 21:46:31 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-05-28 21:46:31 +0000
commitcd39543ce042b6fc392c9805885bd716f15e146b (patch)
tree23aba507cb31843cb3b39379ada139fd25afb8f5 /games-action
parentFix segmentation faults on ia64, bug #180142. (diff)
downloadgentoo-2-cd39543ce042b6fc392c9805885bd716f15e146b.tar.gz
gentoo-2-cd39543ce042b6fc392c9805885bd716f15e146b.tar.bz2
gentoo-2-cd39543ce042b6fc392c9805885bd716f15e146b.zip
Version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/blobandconquer/ChangeLog7
-rw-r--r--games-action/blobandconquer/blobandconquer-0.91.ebuild51
-rw-r--r--games-action/blobandconquer/files/digest-blobandconquer-0.913
3 files changed, 60 insertions, 1 deletions
diff --git a/games-action/blobandconquer/ChangeLog b/games-action/blobandconquer/ChangeLog
index a35428c3aa1d..e332a6f8333d 100644
--- a/games-action/blobandconquer/ChangeLog
+++ b/games-action/blobandconquer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/blobandconquer
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/blobandconquer/ChangeLog,v 1.3 2007/05/06 00:46:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/blobandconquer/ChangeLog,v 1.4 2007/05/28 21:46:31 nyhm Exp $
+
+*blobandconquer-0.91 (28 May 2007)
+
+ 28 May 2007; Tristan Heaven <nyhm@gentoo.org> +blobandconquer-0.91.ebuild:
+ Version bump
*blobandconquer-0.90 (06 May 2007)
diff --git a/games-action/blobandconquer/blobandconquer-0.91.ebuild b/games-action/blobandconquer/blobandconquer-0.91.ebuild
new file mode 100644
index 000000000000..b02a6ef7ffca
--- /dev/null
+++ b/games-action/blobandconquer/blobandconquer-0.91.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/blobandconquer/blobandconquer-0.91.ebuild,v 1.1 2007/05/28 21:46:31 nyhm Exp $
+
+inherit eutils toolchain-funcs games
+
+MY_PN=blobAndConquer
+DESCRIPTION="Mission and objective based 3D action game"
+HOMEPAGE="http://www.parallelrealities.co.uk/blobAndConquer.php"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_compile() {
+ emake \
+ CXX=$(tc-getCXX) \
+ LIBPATH="${LDFLAGS}" \
+ DATADIR="${GAMES_DATADIR}"/${PN}/ \
+ DOCDIR=/usr/share/doc/${PF}/html/ \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${MY_PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data gfx music sound textures || die "doins failed"
+ doicon icons/${MY_PN}.png
+ domenu icons/${MY_PN}.desktop
+ cd doc
+ dohtml -r images pages index.html
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "Until ${PN}-1.0, save games may be incompatible with previous"
+ ewarn "versions."
+}
diff --git a/games-action/blobandconquer/files/digest-blobandconquer-0.91 b/games-action/blobandconquer/files/digest-blobandconquer-0.91
new file mode 100644
index 000000000000..7d1fb13088d5
--- /dev/null
+++ b/games-action/blobandconquer/files/digest-blobandconquer-0.91
@@ -0,0 +1,3 @@
+MD5 b96c6bb80b0be8f46df2af3c1a716e86 blobAndConquer-0.91-1.tar.gz 37546582
+RMD160 3dd777c0eb944d1f4e44b52e6ec5c0112f5b8bcf blobAndConquer-0.91-1.tar.gz 37546582
+SHA256 121b29b535c20f861126d5660a1804905a0704859b3a06d916def5e1dcf760dd blobAndConquer-0.91-1.tar.gz 37546582