summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-06-14 21:35:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-06-14 21:35:45 +0000
commit40eb6e3fd8a308544b33dc8e804b6da2b24f3ab8 (patch)
treee3f6ab33c0450eec20832dafb02d49e6ed37145d /games-action/rrootage
parentInstall more docs, and confirmed to work on ARM (using MV78100). (diff)
downloadgentoo-2-40eb6e3fd8a308544b33dc8e804b6da2b24f3ab8.tar.gz
gentoo-2-40eb6e3fd8a308544b33dc8e804b6da2b24f3ab8.tar.bz2
gentoo-2-40eb6e3fd8a308544b33dc8e804b6da2b24f3ab8.zip
add use deps; respect CC, CXX, {CC,CXX,LD}FLAGS
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-action/rrootage')
-rw-r--r--games-action/rrootage/ChangeLog6
-rw-r--r--games-action/rrootage/rrootage-0.23a.ebuild21
2 files changed, 21 insertions, 6 deletions
diff --git a/games-action/rrootage/ChangeLog b/games-action/rrootage/ChangeLog
index 884dd4c413af..3281519f3f39 100644
--- a/games-action/rrootage/ChangeLog
+++ b/games-action/rrootage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/rrootage
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rrootage/ChangeLog,v 1.9 2010/01/25 22:15:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/rrootage/ChangeLog,v 1.10 2010/06/14 21:35:45 mr_bones_ Exp $
+
+ 14 Jun 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ rrootage-0.23a.ebuild:
+ add use deps; respect CC, CXX, {CC,CXX,LD}FLAGS
25 Jan 2010; Michael Sterrett <mr_bones_@gentoo.org>
rrootage-0.23a.ebuild:
diff --git a/games-action/rrootage/rrootage-0.23a.ebuild b/games-action/rrootage/rrootage-0.23a.ebuild
index 4c2dfbd1f351..1dae3698cbb6 100644
--- a/games-action/rrootage/rrootage-0.23a.ebuild
+++ b/games-action/rrootage/rrootage-0.23a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rrootage/rrootage-0.23a.ebuild,v 1.9 2010/01/25 22:15:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/rrootage/rrootage-0.23a.ebuild,v 1.10 2010/06/14 21:35:45 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -19,15 +19,23 @@ IUSE=""
DEPEND="virtual/opengl
virtual/glu
- media-libs/libsdl
- media-libs/sdl-mixer
+ media-libs/libsdl[video]
+ media-libs/sdl-mixer[vorbis]
>=dev-libs/libbulletml-0.0.3"
S=${WORKDIR}/${MY_PN}/src
src_prepare() {
epatch "${FILESDIR}/${P}"-gcc41.patch
- sed -e "s/-lglut/-lGL -lGLU/" makefile.lin > Makefile || die "sed failed"
+ sed \
+ -e "s/-lglut/-lGL -lGLU/" \
+ -e "/^CC/d" \
+ -e "/^CXX/d" \
+ -e "/^LDFLAGS/s/=/+=/" \
+ -e "/^CPPFLAGS/s/MORE_CFLAGS/MORE_CXXFLAGS/" \
+ -e "/^CPPFLAGS/s/MORE_CFLAGS/MORE_CXXFLAGS/" \
+ -e "s:-I./bulletml/:-I/usr/include/bulletml:" \
+ makefile.lin > Makefile || die "sed failed"
sed -i \
-e "s:/usr/share/games:${GAMES_DATADIR}:" \
@@ -36,7 +44,10 @@ src_prepare() {
}
src_compile() {
- emake MORE_CFLAGS="${CFLAGS}" || die "emake failed"
+ emake \
+ MORE_CFLAGS="-DLINUX ${CFLAGS}" \
+ MORE_CXXFLAGS="-DLINUX ${CXXFLAGS}" \
+ || die "emake failed"
}
src_install() {