summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-31 03:45:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-31 03:45:32 +0000
commit99f698ebe22e945d9d750ac7f79b43967c1f4878 (patch)
tree3b0c02198126c5b0f5bf788f3821ac4f862dceb8 /games-action/postalplus
parentVersion bump (diff)
downloadgentoo-2-99f698ebe22e945d9d750ac7f79b43967c1f4878.tar.gz
gentoo-2-99f698ebe22e945d9d750ac7f79b43967c1f4878.tar.bz2
gentoo-2-99f698ebe22e945d9d750ac7f79b43967c1f4878.zip
initial commit - ebuild submitted by Paul Bredbury via bug #117096
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-action/postalplus')
-rw-r--r--games-action/postalplus/ChangeLog10
-rw-r--r--games-action/postalplus/metadata.xml5
-rw-r--r--games-action/postalplus/postalplus-1.ebuild41
3 files changed, 56 insertions, 0 deletions
diff --git a/games-action/postalplus/ChangeLog b/games-action/postalplus/ChangeLog
new file mode 100644
index 000000000000..a887373b2a23
--- /dev/null
+++ b/games-action/postalplus/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/postalplus
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/postalplus/ChangeLog,v 1.1 2009/01/31 03:45:32 mr_bones_ Exp $
+
+*postalplus-1 (31 Jan 2009)
+
+ 31 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +postalplus-1.ebuild:
+ initial commit - ebuild submitted by Paul Bredbury via bug #117096
+
diff --git a/games-action/postalplus/metadata.xml b/games-action/postalplus/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/postalplus/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/postalplus/postalplus-1.ebuild b/games-action/postalplus/postalplus-1.ebuild
new file mode 100644
index 000000000000..e608223c3699
--- /dev/null
+++ b/games-action/postalplus/postalplus-1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/postalplus/postalplus-1.ebuild,v 1.1 2009/01/31 03:45:32 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Ultraviolent and controversial game featuring the Postal Dude"
+HOMEPAGE="http://www.lokigames.com/products/postal/"
+SRC_URI=""
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}
+
+GAMES_CHECK_LICENSE="yes"
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ cdrom_get_cds postal_plus.ini
+ exeinto "${dir}"
+ doexe "${CDROM_ROOT}"/bin/x86/postal || die
+ insinto "${dir}"
+ doins "${CDROM_ROOT}"/{icon.{bmp,xpm},postal_plus.ini,README} || die
+ cp "${CDROM_ROOT}"/icon.xpm ${PN}.xpm || die
+
+ cp -r "${CDROM_ROOT}"/res "${D}${dir}" || die "cp data failed"
+ find "${D}" -name TRANS.TBL -exec rm '{}' +
+
+ games_make_wrapper ${PN} ./postal "${dir}"
+ doicon ${PN}.xpm
+ make_desktop_entry ${PN} "Postal Plus" ${PN}
+
+ prepgamesdirs
+}