summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-27 11:42:54 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-27 11:42:54 +0000
commit93c4702f47fe7b9d46801c864bf64fecc3bebf58 (patch)
tree5b72736ced779ed168b0f92d904d2dbfb872af60 /games-action/heretic2-demo
parentSupport multilib packages in dependencies. Update/fix dependencies. (diff)
downloadgentoo-2-93c4702f47fe7b9d46801c864bf64fecc3bebf58.tar.gz
gentoo-2-93c4702f47fe7b9d46801c864bf64fecc3bebf58.tar.bz2
gentoo-2-93c4702f47fe7b9d46801c864bf64fecc3bebf58.zip
Support multilib packages in dependencies. Update/fix dependencies. Use ABI=x86 to obtain proper libGL path for config.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-action/heretic2-demo')
-rw-r--r--games-action/heretic2-demo/ChangeLog9
-rw-r--r--games-action/heretic2-demo/heretic2-demo-1.06a.ebuild24
2 files changed, 20 insertions, 13 deletions
diff --git a/games-action/heretic2-demo/ChangeLog b/games-action/heretic2-demo/ChangeLog
index fb5ecf4f8c40..03661de6f600 100644
--- a/games-action/heretic2-demo/ChangeLog
+++ b/games-action/heretic2-demo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/heretic2-demo
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2-demo/ChangeLog,v 1.10 2012/12/27 08:51:42 tupone Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2-demo/ChangeLog,v 1.11 2014/06/27 11:42:54 mgorny Exp $
+
+ 27 Jun 2014; Michał Górny <mgorny@gentoo.org> heretic2-demo-1.06a.ebuild:
+ Support multilib packages in dependencies. Update/fix dependencies. Use
+ ABI=x86 to obtain proper libGL path for config.
27 Dec 2012; Tupone Alfredo <tupone@gentoo.org> heretic2-demo-1.06a.ebuild:
Use QA_PREBUILT. Bug #431230 by Diego Elio Pettenò
@@ -41,4 +45,3 @@
+heretic2-demo-1.06a.ebuild:
Initial import. Ebuild by Paul Bredbury <brebs@sent.com>. Closing bug
#120358.
-
diff --git a/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild b/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild
index 61dcaa6bd1ca..ededbb20f643 100644
--- a/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild
+++ b/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild,v 1.12 2012/12/27 08:51:42 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2-demo/heretic2-demo-1.06a.ebuild,v 1.13 2014/06/27 11:42:54 mgorny Exp $
EAPI=4
inherit eutils unpacker multilib games
@@ -18,14 +18,16 @@ RESTRICT="strip"
QA_TEXTRELS="${GAMES_PREFIX_OPT:1}/heretic2-demo/ref_glx.so"
DEPEND="games-util/loki_patch"
-RDEPEND="x86? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXau
- x11-libs/libXdmcp )
- amd64? (
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-compat )"
+RDEPEND="
+ || (
+ (
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )"
S=${WORKDIR}
@@ -34,6 +36,8 @@ Ddir=${D}/${dir}
QA_PREBUILT="${dir:1}/*"
src_install() {
+ ABI=x86
+
local demo="data/demos/heretic2_demo"
local exe="heretic2_demo.x86"