summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-03-07 21:40:39 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-03-07 21:40:39 +0000
commit46e3a95e1aaa527b7745caca1393e38fe4121678 (patch)
tree80960c94790ee9e46771227b33b55a008bc4ac2d /games-action/descent2-data
parentx86 stable wrt bug 165555 (diff)
downloadgentoo-2-46e3a95e1aaa527b7745caca1393e38fe4121678.tar.gz
gentoo-2-46e3a95e1aaa527b7745caca1393e38fe4121678.tar.bz2
gentoo-2-46e3a95e1aaa527b7745caca1393e38fe4121678.zip
Change the FILESDIR checks to be DISTDIR, so nobody needs to keep a copy fo this in an overlay to use that functionality.
(Portage version: 2.1.2.1)
Diffstat (limited to 'games-action/descent2-data')
-rw-r--r--games-action/descent2-data/ChangeLog7
-rw-r--r--games-action/descent2-data/descent2-data-1.0.ebuild16
2 files changed, 14 insertions, 9 deletions
diff --git a/games-action/descent2-data/ChangeLog b/games-action/descent2-data/ChangeLog
index 3d868c763a93..521eae117f84 100644
--- a/games-action/descent2-data/ChangeLog
+++ b/games-action/descent2-data/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/descent2-data
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/descent2-data/ChangeLog,v 1.2 2007/03/07 15:49:57 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent2-data/ChangeLog,v 1.3 2007/03/07 21:40:39 wolf31o2 Exp $
+
+ 07 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ descent2-data-1.0.ebuild:
+ Change the FILESDIR checks to be DISTDIR, so nobody needs to keep a copy fo
+ this in an overlay to use that functionality.
07 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
descent2-data-1.0.ebuild:
diff --git a/games-action/descent2-data/descent2-data-1.0.ebuild b/games-action/descent2-data/descent2-data-1.0.ebuild
index 1a917f6b9eeb..f694df8962e1 100644
--- a/games-action/descent2-data/descent2-data-1.0.ebuild
+++ b/games-action/descent2-data/descent2-data-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/descent2-data/descent2-data-1.0.ebuild,v 1.3 2007/03/07 15:49:57 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent2-data/descent2-data-1.0.ebuild,v 1.4 2007/03/07 21:40:39 wolf31o2 Exp $
inherit eutils games
@@ -37,13 +37,13 @@ pkg_setup() {
local m f need_cd="n"
- # Could have the ${SOW} file in ${FILESDIR}, in a local overlay
- if [[ -e "${FILESDIR}/${SOW}" ]] ; then
- einfo "Using ${SOW} from ${FILESDIR}"
- # Check that the movies are available in ${FILESDIR} if needed
+ # Could have the ${SOW} file in ${DISTDIR}
+ if [[ -e "${DISTDIR}/${SOW}" ]] ; then
+ einfo "Using ${SOW} from ${DISTDIR}"
+ # Check that the movies are available in ${DISTDIR} if needed
if use videos ; then
for m in {intro,other,robots}-{h,l}.mvl ; do
- [[ -e "${FILESDIR}/${m}" ]] || need_cd="y"
+ [[ -e "${DISTDIR}/${m}" ]] || need_cd="y"
done
fi
else
@@ -57,7 +57,7 @@ pkg_setup() {
}
src_unpack() {
- local m f="${FILESDIR}/${SOW}"
+ local m f="${DISTDIR}/${SOW}"
[[ -e "${f}" ]] || f="${CDROM_ROOT}/d2data/${SOW}"
# Extract level data
@@ -66,7 +66,7 @@ src_unpack() {
if use videos ; then
# Include both high and low resolution movie files
for m in {intro,other,robots}-{h,l}.mvl ; do
- f="${FILESDIR}/${m}"
+ f="${DISTDIR}/${m}"
[[ -e "${f}" ]] || f="${CDROM_ROOT}/d2data/${m}"
einfo "Copying ${m}"
cp -f "${f}" . || die "cp ${f} failed"