summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-12 09:57:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-12 09:57:16 +0000
commite0b54ff4a67ff52b988a0f3085be3498ce091137 (patch)
tree2361d47df365f74c7a5838c956cc563b65d7ba97 /games-action/atanks
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-e0b54ff4a67ff52b988a0f3085be3498ce091137.tar.gz
gentoo-2-e0b54ff4a67ff52b988a0f3085be3498ce091137.tar.bz2
gentoo-2-e0b54ff4a67ff52b988a0f3085be3498ce091137.zip
need eutils for epatch
Diffstat (limited to 'games-action/atanks')
-rw-r--r--games-action/atanks/ChangeLog5
-rw-r--r--games-action/atanks/atanks-1.1.0.ebuild19
2 files changed, 13 insertions, 11 deletions
diff --git a/games-action/atanks/ChangeLog b/games-action/atanks/ChangeLog
index 990337472fa5..58e5c236113b 100644
--- a/games-action/atanks/ChangeLog
+++ b/games-action/atanks/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/atanks
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.8 2004/09/04 20:40:00 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.9 2004/09/12 09:57:16 mr_bones_ Exp $
+
+ 12 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> atanks-1.1.0.ebuild:
+ need eutils for epatch
04 Sep 2004; Daniel Goller <morfic@gentoo.org> +files/atanks-gcc34.patch,
atanks-1.1.0.ebuild:
diff --git a/games-action/atanks/atanks-1.1.0.ebuild b/games-action/atanks/atanks-1.1.0.ebuild
index 67aadf2c423e..97b4366b11ca 100644
--- a/games-action/atanks/atanks-1.1.0.ebuild
+++ b/games-action/atanks/atanks-1.1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-1.1.0.ebuild,v 1.5 2004/09/04 20:40:00 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-1.1.0.ebuild,v 1.6 2004/09/12 09:57:16 mr_bones_ Exp $
-inherit games gcc
+inherit eutils gcc games
DATA_DIR="${GAMES_DATADIR}/${PN}"
DESCRIPTION="Worms and Scorched Earth-like game"
@@ -14,26 +14,25 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-RDEPEND="virtual/x11
+DEPEND="virtual/x11
>=media-libs/allegro-4.0.3
>=media-libs/allegttf-2.0"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
S="${WORKDIR}/${PN}"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
#apply both patches to compile with gcc-3.4.0 closing bug #49457
- if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ if [ "$(gcc-major-version)" -ge "3" -a "$(gcc-minor-version)" -ge "4" ]
then
- epatch ${FILESDIR}/atanks-gcc34.patch
+ epatch "${FILESDIR}/atanks-gcc34.patch"
fi
sed -i \
- -e "s:DATA_DIR=.*:DATA_DIR=\\\\\"${DATA_DIR}\\\\\":" src/Makefile || \
- die "sed src/Makefile failed"
+ -e "s:DATA_DIR=.*:DATA_DIR=\\\\\"${DATA_DIR}\\\\\":" \
+ src/Makefile \
+ || die "sed src/Makefile failed"
}
src_install() {