summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-10-28 07:40:37 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-10-28 07:40:37 +0000
commit3c036577fe62bb414fb5fff128b4d2d9001df592 (patch)
treea8edcf5a876aadd14ebfcf36b9045b0d5d3e94c5 /games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild
parentCorrected the ChangeLog (diff)
downloadgentoo-2-3c036577fe62bb414fb5fff128b4d2d9001df592.tar.gz
gentoo-2-3c036577fe62bb414fb5fff128b4d2d9001df592.tar.bz2
gentoo-2-3c036577fe62bb414fb5fff128b4d2d9001df592.zip
Fixing armagetronad dedicated. Bug #119351
(Portage version: 2.1.1)
Diffstat (limited to 'games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild')
-rw-r--r--games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild b/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild
index fe8e4fc64e5c..c552ef10fdbf 100644
--- a/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild
+++ b/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild,v 1.2 2006/09/08 05:49:06 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild,v 1.3 2006/10/28 07:40:37 tupone Exp $
inherit flag-o-matic eutils games
@@ -35,6 +35,14 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-gcc4.patch
epatch "${FILESDIR}"/${P}-security-1.patch
+ if use dedicated; then
+ cp "${FILESDIR}"/${PN}-ded .
+ sed -i \
+ -e "s:@GAMES_SYSCONFDIR@:${GAMES_SYSCONFDIR}:" \
+ -e "s:@GAMES_LIBDIR@:${GAMES_LIBDIR}:" \
+ -e "s:@GAMES_DATADIR@:${GAMES_DATADIR}:" \
+ ${PN}-ded
+ fi
}
src_compile() {
@@ -68,7 +76,7 @@ src_install() {
insinto "${GAMES_SYSCONFDIR}/${PN}"
doins -r config/* || die "copying files"
if use dedicated; then
- dogamesbin "${FILESDIR}/${PN}-ded"
+ dogamesbin ${PN}-ded
fi
cd "${S}"
insinto "${GAMES_DATADIR}/${PN}"