summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-11-08 10:57:53 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-11-08 10:57:53 +0000
commit493d903a9e88da7d2cc6ece6c6ffa8e652cb7b1e (patch)
treea52791beadb5828c1b8d0f085fd195650c9932e8 /games-action/0verkill
parentx86 stable wrt bug #344333 (diff)
downloadgentoo-2-493d903a9e88da7d2cc6ece6c6ffa8e652cb7b1e.tar.gz
gentoo-2-493d903a9e88da7d2cc6ece6c6ffa8e652cb7b1e.tar.bz2
gentoo-2-493d903a9e88da7d2cc6ece6c6ffa8e652cb7b1e.zip
Fix overflow. Bug #337188
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'games-action/0verkill')
-rw-r--r--games-action/0verkill/0verkill-0.16-r3.ebuild5
-rw-r--r--games-action/0verkill/ChangeLog8
-rw-r--r--games-action/0verkill/files/0verkill-0.16-ovflfix.patch24
3 files changed, 33 insertions, 4 deletions
diff --git a/games-action/0verkill/0verkill-0.16-r3.ebuild b/games-action/0verkill/0verkill-0.16-r3.ebuild
index de18a2702f00..c5aa39f13cba 100644
--- a/games-action/0verkill/0verkill-0.16-r3.ebuild
+++ b/games-action/0verkill/0verkill-0.16-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/0verkill-0.16-r3.ebuild,v 1.7 2010/01/02 23:09:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/0verkill-0.16-r3.ebuild,v 1.8 2010/11/08 10:57:53 tupone Exp $
EAPI=2
inherit autotools eutils games
@@ -22,6 +22,7 @@ src_prepare() {
"${FILESDIR}"/${P}-home-overflow.patch \
"${FILESDIR}"/${P}-segv.patch \
"${FILESDIR}"/${P}-gentoo-paths.patch \
+ "${FILESDIR}"/${P}-ovflfix.patch \
"${FILESDIR}"/${P}-underflow-check.patch #136222
sed -i \
-e "s:data/:${GAMES_DATADIR}/${PN}/data/:" cfg.h \
diff --git a/games-action/0verkill/ChangeLog b/games-action/0verkill/ChangeLog
index 6543cabbfd0f..94ba0cc881be 100644
--- a/games-action/0verkill/ChangeLog
+++ b/games-action/0verkill/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/0verkill
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/ChangeLog,v 1.16 2008/03/07 23:54:07 wolf31o2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/ChangeLog,v 1.17 2010/11/08 10:57:53 tupone Exp $
+
+ 08 Nov 2010; Alfredo Tupone <tupone@gentoo.org> 0verkill-0.16-r3.ebuild,
+ +files/0verkill-0.16-ovflfix.patch:
+ Fix overflow. Bug #337188 by flameeyes@gentoo.org
07 Mar 2008; Chris Gianelloni <wolf31o2@gentoo.org>
0verkill-0.16-r3.ebuild:
diff --git a/games-action/0verkill/files/0verkill-0.16-ovflfix.patch b/games-action/0verkill/files/0verkill-0.16-ovflfix.patch
new file mode 100644
index 000000000000..3df8a0789545
--- /dev/null
+++ b/games-action/0verkill/files/0verkill-0.16-ovflfix.patch
@@ -0,0 +1,24 @@
+--- server.c.old 2010-11-08 11:53:18.000000000 +0100
++++ server.c 2010-11-08 11:53:43.000000000 +0100
+@@ -905,8 +905,8 @@
+ int len;
+
+ packet[0]=P_MESSAGE;
+- if (!name){snprintf(packet+1,256,"%s",msg);len=strlen(msg)+1+1;}
+- else {snprintf(packet+1,256,"%s> %s",name,msg);len=strlen(name)+strlen(msg)+1+3;}
++ if (!name){snprintf(packet+1,255,"%s",msg);len=strlen(msg)+1+1;}
++ else {snprintf(packet+1,255,"%s> %s",name,msg);len=strlen(name)+strlen(msg)+1+3;}
+ send_chunk_packet_to_player(packet,len,player);
+ }
+
+--- console.c.old 2010-11-08 11:53:26.000000000 +0100
++++ console.c 2010-11-08 11:54:44.000000000 +0100
+@@ -206,7 +206,7 @@
+ void c_setcolor_3b(unsigned char a)
+ {
+ char txt[8];
+- snprintf(txt,16,"\033[%dm",30+(a&7));
++ snprintf(txt,sizeof(txt),"\033[%dm",30+(a&7));
+ my_print(txt);
+ }
+