summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-01-04 22:00:27 +0000
committerMike Frysinger <vapier@gentoo.org>2012-01-04 22:00:27 +0000
commitb10562c27004c8ffed901b6a67eb7e5eb064a453 (patch)
tree7803654991095a1b3b0e6b8e350f1e1e1d6d29cc /eclass
parentMarking postfix-2.8.7 ppc for bug 395289 (diff)
downloadgentoo-2-b10562c27004c8ffed901b6a67eb7e5eb064a453.tar.gz
gentoo-2-b10562c27004c8ffed901b6a67eb7e5eb064a453.tar.bz2
gentoo-2-b10562c27004c8ffed901b6a67eb7e5eb064a453.zip
always run automake if the configure file calls AM_INIT_AUTOMAKE #397697 by My Th
Diffstat (limited to 'eclass')
-rw-r--r--eclass/autotools.eclass10
1 files changed, 4 insertions, 6 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index daaa4b09044f..79791e0de275 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.116 2011/12/14 20:46:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.117 2012/01/04 22:00:27 vapier Exp $
# @ECLASS: autotools.eclass
# @MAINTAINER:
@@ -256,14 +256,12 @@ eautomake() {
# Run automake if:
# - a Makefile.am type file exists
- # - a Makefile.in type file exists and the configure
- # script is using the AM_INIT_AUTOMAKE directive
- for makefile_name in {GNUmakefile,{M,m}akefile}.{am,in} "" ; do
+ # - the configure script is using the AM_INIT_AUTOMAKE directive
+ for makefile_name in {GNUmakefile,{M,m}akefile}.am "" ; do
[[ -f ${makefile_name} ]] && break
done
- [[ -z ${makefile_name} ]] && return 0
- if [[ ${makefile_name} == *.in ]] ; then
+ if [[ -z ${makefile_name} ]] ; then
if ! grep -qs AM_INIT_AUTOMAKE configure.?? ; then
return 0
fi