summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-03-05 18:26:20 +0000
committerRichard Brown <rbrown@gentoo.org>2007-03-05 18:26:20 +0000
commit42c7dc378d823484c2f6a934ac013d12824da8de (patch)
treebb4edea6736dd0b40197dda58b6bc2b483b61cc2 /eclass
parentFix broken Manifest due to Attic/ in the header of digikam-0.7.4-r1.ebuild. (diff)
downloadgentoo-2-42c7dc378d823484c2f6a934ac013d12824da8de.tar.gz
gentoo-2-42c7dc378d823484c2f6a934ac013d12824da8de.tar.bz2
gentoo-2-42c7dc378d823484c2f6a934ac013d12824da8de.zip
Allow ebuilds to specify GEM_SRC. From Diego Pettenò <flameeyes@gmail.com>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/gems.eclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/eclass/gems.eclass b/eclass/gems.eclass
index 6d22506d08cb..0beb837329e4 100644
--- a/eclass/gems.eclass
+++ b/eclass/gems.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gems.eclass,v 1.16 2007/01/31 13:46:07 pclouds Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gems.eclass,v 1.17 2007/03/05 18:26:20 rbrown Exp $
#
# Author: Rob Cakebread <pythonhead@gentoo.org>
# Current Maintainer: Ruby Herd <ruby@gentoo.org>
@@ -45,10 +45,10 @@ gems_src_install() {
gems_location
if [ -z "${MY_P}" ]; then
- GEM_SRC=${DISTDIR}/${P}
+ [ -z "${GEM_SRC}" ] && GEM_SRC=${DISTDIR}/${P}
spec_path=${D}/${GEMSDIR}/specifications/${P}.gemspec
else
- GEM_SRC=${DISTDIR}/${MY_P}
+ [ -z "${GEM_SRC}" ] && GEM_SRC=${DISTDIR}/${MY_P}
spec_path=${D}/${GEMSDIR}/specifications/${MY_P}.gemspec
fi