summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-04-22 17:17:47 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-04-22 17:17:47 +0000
commit15e66c1ebd4bb859d9bf78d3b6b381f298fc0e36 (patch)
tree4eee908237ab1dad8bc6be8ab56b61ab9e8449eb /eclass
parentUse newconfd/newinitd for #174266; Properly quote variables. (diff)
downloadgentoo-2-15e66c1ebd4bb859d9bf78d3b6b381f298fc0e36.tar.gz
gentoo-2-15e66c1ebd4bb859d9bf78d3b6b381f298fc0e36.tar.bz2
gentoo-2-15e66c1ebd4bb859d9bf78d3b6b381f298fc0e36.zip
Fixed DOC_DIR_SUFFIX handling. Fixes bug 175538.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kde.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/kde.eclass b/eclass/kde.eclass
index ca47e5a43e38..6b7eea08439c 100644
--- a/eclass/kde.eclass
+++ b/eclass/kde.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.196 2007/04/19 10:24:56 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.197 2007/04/22 17:17:47 philantrop Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
#
@@ -135,7 +135,7 @@ kde_src_unpack() {
if [[ -n ${LANGS_DOC} ]]; then
MAKE_DOC=$(echo $(echo "${LINGUAS} ${LANGS_DOC}" | tr ' ' '\n' | sort | uniq -d))
einfo "Enabling documentation for: ${MAKE_DOC}"
- [[ -n ${MAKE_DOC} ]] && [[ -n ${DOC_DIR_SUFFIX} ]] && MAKE_DOC="${MAKE_DOC/ /${DOC_DIR_SUFFIX} }"
+ [[ -n ${MAKE_DOC} ]] && [[ -n ${DOC_DIR_SUFFIX} ]] && MAKE_DOC="${MAKE_DOC}${DOC_DIR_SUFFIX}"
sed -i -e "s:^SUBDIRS =.*:SUBDIRS = ${MAKE_DOC} ${PN}:" \
"${KDE_S}/doc/Makefile.am" || die "sed for locale failed"
rm -f "${KDE_S}/configure"