summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-01 19:38:52 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-01 19:38:52 +0000
commit4b26c17dcff573da3564a0ed599cc9e60e73c010 (patch)
tree616af4890a6acaa90f3c20bfdf2361fea24b796e /eclass/kde4-meta.eclass
parentVersion bump thanks to Elias Probst and Florian Steinel (bug #277909). (diff)
downloadgentoo-2-4b26c17dcff573da3564a0ed599cc9e60e73c010.tar.gz
gentoo-2-4b26c17dcff573da3564a0ed599cc9e60e73c010.tar.bz2
gentoo-2-4b26c17dcff573da3564a0ed599cc9e60e73c010.zip
Make .xz compression as default for SRC_URI calculation. Add KDE prefix to BUILD_TYPE. No #DONOTCOMPILE if add_subdirectory has a variable parameter ("${...").
Diffstat (limited to 'eclass/kde4-meta.eclass')
-rw-r--r--eclass/kde4-meta.eclass36
1 files changed, 18 insertions, 18 deletions
diff --git a/eclass/kde4-meta.eclass b/eclass/kde4-meta.eclass
index aff57c62e43f..66287e302381 100644
--- a/eclass/kde4-meta.eclass
+++ b/eclass/kde4-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.64 2012/05/08 22:00:49 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.65 2012/08/01 19:38:52 johu Exp $
#
# @ECLASS: kde4-meta.eclass
# @MAINTAINER:
@@ -69,7 +69,7 @@ debug-print "line ${LINENO} ${ECLASS}: DEPEND ${DEPEND} - after metapackage-spec
debug-print "line ${LINENO} ${ECLASS}: RDEPEND ${RDEPEND} - after metapackage-specific dependencies"
# Useful to build kde4-meta style stuff from extragear/playground (plasmoids etc)
-case ${BUILD_TYPE} in
+case ${KDE_BUILD_TYPE} in
live)
if [[ ${KDE_SCM} == svn ]]; then
case ${KMNAME} in
@@ -147,7 +147,7 @@ kde4-meta_pkg_setup() {
kde4-meta_src_unpack() {
debug-print-function ${FUNCNAME} "$@"
- if [[ ${BUILD_TYPE} = live ]]; then
+ if [[ ${KDE_BUILD_TYPE} = live ]]; then
case "${KDE_SCM}" in
svn)
migrate_store_dir
@@ -173,7 +173,7 @@ kde4-meta_src_unpack() {
kde4-meta_src_extract() {
debug-print-function ${FUNCNAME} "$@"
- if [[ ${BUILD_TYPE} = live ]]; then
+ if [[ ${KDE_BUILD_TYPE} = live ]]; then
# Export working copy to ${S}
einfo "Exporting parts of working copy to ${S}"
kde4-meta_create_extractlists
@@ -210,12 +210,12 @@ kde4-meta_src_extract() {
else
local abort tarball tarfile f extractlist postfix
- if [[ ${PV} =~ 4.8.[12345] ]]; then
- postfix="xz"
- KMTARPARAMS+=" --xz"
- else
+ if [[ ${PV} =~ 4.7.[12345] ]]; then
postfix="bz2"
KMTARPARAMS+=" --bzip2"
+ else
+ postfix="xz"
+ KMTARPARAMS+=" --xz"
fi
case ${KMNAME} in
@@ -312,6 +312,7 @@ kde4-meta_create_extractlists() {
;;
kdebase-runtime | kde-runtime)
KMEXTRACTONLY+="
+ CTestConfig.cmake
config-runtime.h.cmake"
;;
kdebase-workspace | kde-workspace)
@@ -380,16 +381,8 @@ kde4-meta_create_extractlists() {
&& ! [[ ${KMNAME} == kdeedu && ( ${PV} == 4.6.4 || ${PV} == 4.6.5 ) ]]; then
case ${KMNAME} in
kdebase-runtime|kde-runtime|kdebase-workspace|kde-workspace|kdeedu|kdegames|kdegraphics)
- case ${PN} in
- libkdegames|libkdeedu|libkworkspace)
- KMEXTRA+="
- cmake/modules/"
- ;;
- *)
- KMCOMPILEONLY+="
- cmake/modules/"
- ;;
- esac
+ KMEXTRACTONLY+="
+ cmake/modules/"
;;
esac
fi
@@ -495,6 +488,13 @@ kde4-meta_change_cmakelists() {
-i CMakeLists.txt || die "${LINENO}: cmake sed died"
fi
+ # Restore "add_subdirectory( ${ ..." (this is done in kdesdk)
+ if [[ -f CMakeLists.txt ]]; then
+ sed -e '/add_subdirectory[[:space:]]*([[:space:]]*\${/s/^#DONOTCOMPILE //' \
+ -e '/ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*\${/s/^#DONOTCOMPILE //' \
+ -i CMakeLists.txt || die "${LINENO}: cmake sed died"
+ fi
+
if [[ -z ${KMNOMODULE} ]]; then
# Restore "add_subdirectory" in $KMMODULE subdirectories
find "${S}"/${KMMODULE} -name CMakeLists.txt -print0 | \