summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-23 21:20:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-23 21:20:35 +0000
commit2c4dc71734a7b4de76f3ecb2ebf061547cc88067 (patch)
treebd8ce6537c4182e963cf2e7193baac5d954c32e0 /eclass/kde.eclass
parentBug #148839 - fix *DEPEND. (diff)
downloadgentoo-2-2c4dc71734a7b4de76f3ecb2ebf061547cc88067.tar.gz
gentoo-2-2c4dc71734a7b4de76f3ecb2ebf061547cc88067.tar.bz2
gentoo-2-2c4dc71734a7b4de76f3ecb2ebf061547cc88067.zip
Replace the detect-autoconf.sh script with a dummy one, avoids tools picking up automake 1.7 when available.
Diffstat (limited to 'eclass/kde.eclass')
-rw-r--r--eclass/kde.eclass32
1 files changed, 22 insertions, 10 deletions
diff --git a/eclass/kde.eclass b/eclass/kde.eclass
index cb5a9594da95..062011230aaa 100644
--- a/eclass/kde.eclass
+++ b/eclass/kde.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.180 2006/09/21 23:32:44 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.181 2006/09/23 21:20:35 flameeyes Exp $
#
# Author Dan Armak <danarmak@gentoo.org>
#
@@ -215,20 +215,32 @@ kde_src_compile() {
debug-print-section configure
debug-print "$FUNCNAME::configure: myconf=$myconf"
- # This is needed to fix building with autoconf 2.60.
- # Many thanks to who preferred such a stupid check rather
- # than a working arithmetic comparison.
- if [[ -f admin/cvs.sh ]]; then
- sed -i -e '/case $AUTO\(CONF\|HEADER\)_VERSION in/,+1 s/2\.5/2.[56]/g' \
- admin/cvs.sh
- fi
-
- einfo "Forcing automake ${WANT_AUTOMAKE} (hopefully)"
export WANT_AUTOMAKE
# rebuild configure script, etc
# This can happen with e.g. a cvs snapshot
if [ ! -f "./configure" ] || [ -n "$UNSERMAKE" ]; then
+ # This is needed to fix building with autoconf 2.60.
+ # Many thanks to who preferred such a stupid check rather
+ # than a working arithmetic comparison.
+ if [[ -f admin/cvs.sh ]]; then
+ sed -i -e '/case $AUTO\(CONF\|HEADER\)_VERSION in/,+1 s/2\.5/2.[56]/g' \
+ admin/cvs.sh
+ fi
+
+ # Replace the detection script with a dummy, let our wrappers do the work
+ if [[ -f admin/detect-autoconf.sh ]]; then
+ cat - > admin/detect-autoconf.sh <<EOF
+#!/bin/sh
+export AUTOCONF="autoconf"
+export AUTOHEADER="autoheader"
+export AUTOM4TE="autom4te"
+export AUTOMAKE="automake"
+export ACLOCAL="aclocal"
+export WHICH="which"
+EOF
+ fi
+
for x in Makefile.cvs admin/Makefile.common; do
if [ -f "$x" ] && [ -z "$makefile" ]; then makefile="$x"; fi
done