summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-10-09 08:41:41 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-10-09 08:41:41 +0000
commit7ed0241f4a6f05566eb597a9e7c130cc1a0086c5 (patch)
treed99101840b0d14822f08739d10629da1f259ff45 /eclass/distutils.eclass
parentunmasking wxGTK and wxPython 2.4.2 (diff)
downloadgentoo-2-7ed0241f4a6f05566eb597a9e7c130cc1a0086c5.tar.gz
gentoo-2-7ed0241f4a6f05566eb597a9e7c130cc1a0086c5.tar.bz2
gentoo-2-7ed0241f4a6f05566eb597a9e7c130cc1a0086c5.zip
adding hook to disable runtime compiling of pyc
Diffstat (limited to 'eclass/distutils.eclass')
-rw-r--r--eclass/distutils.eclass6
1 files changed, 5 insertions, 1 deletions
diff --git a/eclass/distutils.eclass b/eclass/distutils.eclass
index 3dc91edb7f72..72ec564c7e56 100644
--- a/eclass/distutils.eclass
+++ b/eclass/distutils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.15 2003/10/02 23:14:17 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.16 2003/10/09 08:41:41 liquidx Exp $
#
# Author: Jon Nelson <jnelson@gentoo.org>
# Current Maintainer: Alastair Tse <liquidx@gentoo.org>
@@ -19,6 +19,8 @@
# PYTHON_SLOT_VERSION - for Zope support
# DOCS - additional DOCS
+inherit python
+
ECLASS=distutils
INHERITED="$INHERITED $ECLASS"
@@ -33,10 +35,12 @@ else
fi
distutils_src_compile() {
+ python_disable_pyc
${python} setup.py build "$@" || die "compilation failed"
}
distutils_src_install() {
+ python_disable_pyc
${python} setup.py install --root=${D} "$@" || die
dodoc CHANGELOG COPYRIGHT KNOWN_BUGS MAINTAINERS PKG-INFO