summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-11-16 23:06:41 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-11-16 23:06:41 +0000
commit9c7b66c4dfa802ccfe1acb2be95e72e35515e401 (patch)
treea1338623c091b2cb9a300fe7eb9e4a4af59bed6d /dev-vcs
parentRemove old version. (diff)
downloadgentoo-2-9c7b66c4dfa802ccfe1acb2be95e72e35515e401.tar.gz
gentoo-2-9c7b66c4dfa802ccfe1acb2be95e72e35515e401.tar.bz2
gentoo-2-9c7b66c4dfa802ccfe1acb2be95e72e35515e401.zip
Fix FEATURES=test failure on ghci-less platforms (alpha, ia64, ppc64)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/darcs/ChangeLog6
-rw-r--r--dev-vcs/darcs/darcs-2.4.4-r1.ebuild3
-rw-r--r--dev-vcs/darcs/files/darcs-2.4.4-tests-emailformat.patch39
3 files changed, 46 insertions, 2 deletions
diff --git a/dev-vcs/darcs/ChangeLog b/dev-vcs/darcs/ChangeLog
index 088e4d2bbcec..38c17f7a7b24 100644
--- a/dev-vcs/darcs/ChangeLog
+++ b/dev-vcs/darcs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/darcs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/darcs/ChangeLog,v 1.15 2010/10/19 22:06:39 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/darcs/ChangeLog,v 1.16 2010/11/16 23:06:41 slyfox Exp $
+
+ 16 Nov 2010; Sergei Trofimovich <slyfox@gentoo.org> darcs-2.4.4-r1.ebuild,
+ +files/darcs-2.4.4-tests-emailformat.patch:
+ Fix FEATURES=test failure on ghci-less platforms (alpha, ia64, ppc64)
19 Oct 2010; Thomas Kahle <tomka@gentoo.org> darcs-2.4.4-r1.ebuild:
x86 stable per bug 339580
diff --git a/dev-vcs/darcs/darcs-2.4.4-r1.ebuild b/dev-vcs/darcs/darcs-2.4.4-r1.ebuild
index 9427422fb8cc..e464b91634b2 100644
--- a/dev-vcs/darcs/darcs-2.4.4-r1.ebuild
+++ b/dev-vcs/darcs/darcs-2.4.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/darcs/darcs-2.4.4-r1.ebuild,v 1.8 2010/10/19 22:06:39 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/darcs/darcs-2.4.4-r1.ebuild,v 1.9 2010/11/16 23:06:41 slyfox Exp $
EAPI="2"
CABAL_FEATURES="bin lib profile haddock"
@@ -65,6 +65,7 @@ src_prepare() {
popd
epatch "${FILESDIR}/${P}-issue1770-curl_multi_perform-no-running-handles.patch"
+ epatch "${FILESDIR}/${P}-tests-emailformat.patch"
# Loosen dependency on hashed-storage
sed -i -e "s/hashed-storage == 0.4.13/hashed-storage == 0.4.*/" \
diff --git a/dev-vcs/darcs/files/darcs-2.4.4-tests-emailformat.patch b/dev-vcs/darcs/files/darcs-2.4.4-tests-emailformat.patch
new file mode 100644
index 000000000000..e1fe5dfe8f1d
--- /dev/null
+++ b/dev-vcs/darcs/files/darcs-2.4.4-tests-emailformat.patch
@@ -0,0 +1,39 @@
+Tue Nov 16 23:36:37 EET 2010 Sergei Trofimovich <slyfox@community.haskell.org>
+ * tests/emailformat.sh: use ghc --make instead of ghci
+
+ linux-alpha and linux-ia64 don't have ghci support.
+ No need to fail there.
+diff -rN -u old-darcs.net/tests/emailformat.sh new-darcs.net/tests/emailformat.sh
+--- old-darcs.net/tests/emailformat.sh 2010-11-16 23:40:10.207480789 +0200
++++ new-darcs.net/tests/emailformat.sh 2010-11-16 23:40:10.706480789 +0200
+@@ -6,8 +6,10 @@
+ switch_to_latin9_locale
+ rm -rf temp1
+ rm -rf temp2
++rm -rf temp3
+ mkdir temp1
+ mkdir temp2
++mkdir temp3
+ cd temp1
+
+ seventysevenaddy="<aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa@bbbbbbbbbb.cccccccccc.abrasoft.com>"
+@@ -34,10 +36,17 @@
+ grep $seventysevenaddy mail_as_file
+
+ # Check that there are no non-ASCII characters in the mail
+-ghc -e 'getContents >>= return . not . any (> Data.Char.chr 127)' < mail_as_file | grep '^True$'
++cd ../temp3
++cat > is_ascii.hs <<EOF
++import Data.Char (chr)
+
++main = getContents >>= print . not . any (> Data.Char.chr 127)
++EOF
++
++ghc --make is_ascii.hs -o is_ascii
++./is_ascii < ../temp1/mail_as_file | grep '^True$'
+
+ cd ..
+ rm -rf temp1
+ rm -rf temp2
+-
++rm -rf temp3