summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-12-31 20:36:09 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-12-31 20:36:09 +0000
commit861a5ccddceacc3afbf99cc648908559f05446e9 (patch)
tree9c86e0ae4a610d5430fe9e38d2c6a81c73bf8763 /dev-vcs
parentVersion bump. Remove old. (diff)
downloadgentoo-2-861a5ccddceacc3afbf99cc648908559f05446e9.tar.gz
gentoo-2-861a5ccddceacc3afbf99cc648908559f05446e9.tar.bz2
gentoo-2-861a5ccddceacc3afbf99cc648908559f05446e9.zip
Version bump and switch to ESRs homepage. Requested by Christoph Junghans in bug #449504.
(Portage version: 2.2.0_alpha149_p11/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cvsps/ChangeLog8
-rw-r--r--dev-vcs/cvsps/cvsps-3.3.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-vcs/cvsps/ChangeLog b/dev-vcs/cvsps/ChangeLog
index 4e097d155c10..db73a1ae4778 100644
--- a/dev-vcs/cvsps/ChangeLog
+++ b/dev-vcs/cvsps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/cvsps
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/ChangeLog,v 1.12 2012/10/02 15:58:59 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/ChangeLog,v 1.13 2012/12/31 20:36:09 slyfox Exp $
+
+*cvsps-3.3 (31 Dec 2012)
+
+ 31 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org> +cvsps-3.3.ebuild:
+ Version bump and switch to ESRs homepage. Requested by Christoph Junghans in
+ bug #449504.
*cvsps-2.2_beta1 (02 Oct 2012)
diff --git a/dev-vcs/cvsps/cvsps-3.3.ebuild b/dev-vcs/cvsps/cvsps-3.3.ebuild
new file mode 100644
index 000000000000..fe180ddfaa4e
--- /dev/null
+++ b/dev-vcs/cvsps/cvsps-3.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/cvsps-3.3.ebuild,v 1.1 2012/12/31 20:36:09 slyfox Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Generates patchset information from a CVS repository"
+HOMEPAGE="http://www.catb.org/~esr/cvsps/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+src_prepare() {
+ sed -i 's/ -lz/& $(LDFLAGS)/' Makefile || die
+
+ tc-export CC
+ export prefix=${D}
+}
+
+src_install() {
+ default
+ dodoc README
+}