summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-09-23 11:38:21 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-09-23 11:38:21 +0000
commit7285be683eceb068cbaea423726667dd14ea8e93 (patch)
tree30fdbc73d13ca5c42c922e77e4004b491552c939 /dev-vcs
parentDrop stable keywords from s390 and sh (diff)
downloadgentoo-2-7285be683eceb068cbaea423726667dd14ea8e93.tar.gz
gentoo-2-7285be683eceb068cbaea423726667dd14ea8e93.tar.bz2
gentoo-2-7285be683eceb068cbaea423726667dd14ea8e93.zip
Revision bump: EAPI 5, distutils-r1 eclass, add Prefix support wrt bug #485730. Thanks to Dennis Lan <dennis.yxun AT gmail.com> for providing initial ebuild diff
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/stgit/ChangeLog9
-rw-r--r--dev-vcs/stgit/stgit-0.16-r2.ebuild77
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-vcs/stgit/ChangeLog b/dev-vcs/stgit/ChangeLog
index 6a8b59f6b65e..7801fe5da6f0 100644
--- a/dev-vcs/stgit/ChangeLog
+++ b/dev-vcs/stgit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-vcs/stgit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/stgit/ChangeLog,v 1.18 2013/07/22 02:44:40 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/stgit/ChangeLog,v 1.19 2013/09/23 11:38:21 pinkbyte Exp $
+
+*stgit-0.16-r2 (23 Sep 2013)
+
+ 23 Sep 2013; Sergey Popov <pinkbyte@gentoo.org> +stgit-0.16-r2.ebuild:
+ Revision bump: EAPI 5, distutils-r1 eclass, add Prefix support wrt bug
+ #485730. Thanks to Dennis Lan <dennis.yxun AT gmail.com> for providing
+ initial ebuild diff
22 Jul 2013; Patrick Lauer <patrick@gentoo.org> -stgit-0.15-r1.ebuild,
-stgit-0.16.ebuild:
diff --git a/dev-vcs/stgit/stgit-0.16-r2.ebuild b/dev-vcs/stgit/stgit-0.16-r2.ebuild
new file mode 100644
index 000000000000..bb88fcea3d39
--- /dev/null
+++ b/dev-vcs/stgit/stgit-0.16-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/stgit/stgit-0.16-r2.ebuild,v 1.1 2013/09/23 11:38:21 pinkbyte Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-missing-patches.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future.
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-asciidoc-compat.patch"
+ "${FILESDIR}/${P}-man-linkfix.patch"
+)
+
+pkg_setup() {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+python_prepare_all() {
+ # this will be a noop, as we are working with a tarball,
+ # but throws git errors --> just get rid of it
+ sed -i -e 's/version\.write_builtin_version()//' setup.py || die
+
+ # Workaround hardcoded prefix
+ sed -i -e "/prefix/s|/usr|${EPREFIX}/usr|" setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ doc
+ fi
+}
+
+python_install_all() {
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ install-doc install-html
+ fi
+
+ distutils-r1_python_install_all
+
+ newbashcomp stgit-completion.bash ${PN}
+}