summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-27 23:23:25 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-27 23:23:25 +0000
commit90c60f1e183d940f58ae9b52ce9119785786471e (patch)
tree2d1471a87abd91e5e9a799a3472dc70438842d41 /dev-vcs/stgit/stgit-0.14.3.ebuild
parentpunt old. broken with libnotify 0.7 (diff)
downloadgentoo-2-90c60f1e183d940f58ae9b52ce9119785786471e.tar.gz
gentoo-2-90c60f1e183d940f58ae9b52ce9119785786471e.tar.bz2
gentoo-2-90c60f1e183d940f58ae9b52ce9119785786471e.zip
Use Python 2 (bug #329491).
(Portage version: 2.2.0_alpha28_p40/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/stgit/stgit-0.14.3.ebuild')
-rw-r--r--dev-vcs/stgit/stgit-0.14.3.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-vcs/stgit/stgit-0.14.3.ebuild b/dev-vcs/stgit/stgit-0.14.3.ebuild
index 324094908294..243855f50431 100644
--- a/dev-vcs/stgit/stgit-0.14.3.ebuild
+++ b/dev-vcs/stgit/stgit-0.14.3.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/stgit/stgit-0.14.3.ebuild,v 1.2 2010/03/17 16:32:55 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/stgit/stgit-0.14.3.ebuild,v 1.3 2011/03/27 23:23:25 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
inherit distutils bash-completion
@@ -16,6 +19,11 @@ IUSE=""
RDEPEND=">=dev-vcs/git-1.5"
DEPEND="$RDEPEND"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_install() {
sed -i -e 's-\(prefix:\) ~-\1 /usr-' setup.cfg
distutils_src_install