summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-12-21 23:11:09 +0000
committerMike Gilbert <floppym@gentoo.org>2011-12-21 23:11:09 +0000
commit1b00d0ac248cdf57976ba52c4536e9210c812c3a (patch)
treec6f3bff1c78677a518e1d5b33b56aec566286b8f /dev-vcs/hgsubversion/hgsubversion-9999.ebuild
parentNew version using the 120 api (diff)
downloadgentoo-2-1b00d0ac248cdf57976ba52c4536e9210c812c3a.tar.gz
gentoo-2-1b00d0ac248cdf57976ba52c4536e9210c812c3a.tar.bz2
gentoo-2-1b00d0ac248cdf57976ba52c4536e9210c812c3a.zip
Add live ebuild and clean up style of DEPEND variables.
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/hgsubversion/hgsubversion-9999.ebuild')
-rw-r--r--dev-vcs/hgsubversion/hgsubversion-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-vcs/hgsubversion/hgsubversion-9999.ebuild b/dev-vcs/hgsubversion/hgsubversion-9999.ebuild
new file mode 100644
index 000000000000..f70800ed87ac
--- /dev/null
+++ b/dev-vcs/hgsubversion/hgsubversion-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/hgsubversion-9999.ebuild,v 1.1 2011/12/21 23:11:09 floppym Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils mercurial
+
+DESCRIPTION="hgsubversion is a Mercurial extension for working with Subversion repositories."
+HOMEPAGE="https://bitbucket.org/durin42/hgsubversion/wiki/Home http://pypi.python.org/pypi/hgsubversion"
+SRC_URI=""
+EHG_REPO_URI="https://bitbucket.org/durin42/hgsubversion"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="
+ >=dev-vcs/mercurial-1.4
+ || (
+ dev-python/subvertpy
+ >=dev-vcs/subversion-1.5[python]
+ )
+"
+DEPEND="
+ dev-python/setuptools
+ test? ( dev-python/nose )
+"
+
+DOCS="README"
+
+src_test() {
+ cd tests
+
+ testing() {
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" run.py
+ }
+ python_execute_function testing
+}