summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-09-28 14:36:38 +0000
committerSebastian Pipping <sping@gentoo.org>2011-09-28 14:36:38 +0000
commit38c076f27591023accb785ea44a357af1cd84846 (patch)
tree150bfb2bb237c1d09d8605371c7f82ffb6bab9ee /dev-vcs/gitg
parentMake sure the esound module doesn't break things and some log fixes. (diff)
downloadgentoo-2-38c076f27591023accb785ea44a357af1cd84846.tar.gz
gentoo-2-38c076f27591023accb785ea44a357af1cd84846.tar.bz2
gentoo-2-38c076f27591023accb785ea44a357af1cd84846.zip
dev-vcs/gitg: Bump to 0.2.5 (bug #383527)
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/gitg')
-rw-r--r--dev-vcs/gitg/ChangeLog7
-rw-r--r--dev-vcs/gitg/gitg-0.2.5.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-vcs/gitg/ChangeLog b/dev-vcs/gitg/ChangeLog
index e48d715b2cbb..8a22eca31032 100644
--- a/dev-vcs/gitg/ChangeLog
+++ b/dev-vcs/gitg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/gitg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.14 2011/08/07 07:24:00 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.15 2011/09/28 14:36:38 sping Exp $
+
+*gitg-0.2.5 (28 Sep 2011)
+
+ 28 Sep 2011; Sebastian Pipping <sping@gentoo.org> +gitg-0.2.5.ebuild:
+ Bump to 0.2.5 (bug #383527)
07 Aug 2011; Zac Medico <zmedico@gentoo.org> gitg-0.2.4.ebuild:
Add ~x86-linux keyword.
diff --git a/dev-vcs/gitg/gitg-0.2.5.ebuild b/dev-vcs/gitg/gitg-0.2.5.ebuild
new file mode 100644
index 000000000000..27551a33d2d3
--- /dev/null
+++ b/dev-vcs/gitg/gitg-0.2.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/gitg-0.2.5.ebuild,v 1.1 2011/09/28 14:36:38 sping Exp $
+
+EAPI="3"
+GNOME2_LA_PUNT="yes"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="git repository viewer for GNOME"
+HOMEPAGE="http://trac.novowork.com/gitg/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+# FIXME: debug changes CFLAGS
+IUSE="debug glade"
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-3.0.0:3
+ >=x11-libs/gtksourceview-3.1.3:3.0
+ >=gnome-base/gconf-2.10:2
+ >=gnome-base/gsettings-desktop-schemas-0.1.1
+ dev-vcs/git
+ glade? ( >=dev-util/glade-3.2:3.10 )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/pkgconfig-0.15
+ >=dev-util/intltool-0.40"
+
+pkg_setup() {
+ # Disable maintainer to get rid of -Werror (bug #363009)
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-deprecations
+ --disable-dependency-tracking
+ --disable-maintainer-mode
+ $(use_enable debug)
+ $(use_enable glade glade-catalog)"
+
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_test() {
+ emake check || die
+}