summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-10 18:44:21 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-10 18:44:21 +0000
commitc65d6f674bbef286404954153dc0290a97ee9a57 (patch)
treea20ca7975c4920c410bb9ba36976cb202c849ca8 /dev-vcs/git
parentstable ppc, bug 347537 (diff)
downloadgentoo-2-c65d6f674bbef286404954153dc0290a97ee9a57.tar.gz
gentoo-2-c65d6f674bbef286404954153dc0290a97ee9a57.tar.bz2
gentoo-2-c65d6f674bbef286404954153dc0290a97ee9a57.zip
Call python_mod_optimize() and python_mod_cleanup() (bug #329479).
(Portage version: 2.2.0_alpha14_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/git')
-rw-r--r--dev-vcs/git/ChangeLog6
-rw-r--r--dev-vcs/git/git-1.7.3.5-r2.ebuild4
-rw-r--r--dev-vcs/git/git-1.7.4_rc1-r2.ebuild4
-rw-r--r--dev-vcs/git/git-9999.ebuild4
4 files changed, 14 insertions, 4 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index 53288b45c918..f63d2c336010 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.80 2011/01/08 10:53:10 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.81 2011/01/10 18:44:21 arfrever Exp $
+
+ 10 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ git-1.7.3.5-r2.ebuild, git-1.7.4_rc1-r2.ebuild, git-9999.ebuild:
+ Call python_mod_optimize() and python_mod_cleanup() (bug #329479).
08 Jan 2011; Fabian Groffen <grobian@gentoo.org> git-1.7.3.5-r2.ebuild,
git-1.7.4_rc1-r2.ebuild, git-9999.ebuild:
diff --git a/dev-vcs/git/git-1.7.3.5-r2.ebuild b/dev-vcs/git/git-1.7.3.5-r2.ebuild
index 53b3cf9415da..60c4a822ba13 100644
--- a/dev-vcs/git/git-1.7.3.5-r2.ebuild
+++ b/dev-vcs/git/git-1.7.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.5-r2.ebuild,v 1.4 2011/01/08 14:11:18 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.5-r2.ebuild,v 1.5 2011/01/10 18:44:21 arfrever Exp $
EAPI=3
@@ -492,6 +492,7 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
+ use python && python_mod_optimize git_remote_helpers
if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
ewarn "You must build dev-vcs/subversion with USE=perl"
ewarn "to get the full functionality of git-svn!"
@@ -506,4 +507,5 @@ pkg_postinst() {
pkg_postrm() {
use emacs && elisp-site-regen
+ use python && python_mod_cleanup git_remote_helpers
}
diff --git a/dev-vcs/git/git-1.7.4_rc1-r2.ebuild b/dev-vcs/git/git-1.7.4_rc1-r2.ebuild
index db2f27b75c5e..c4b66beb40c7 100644
--- a/dev-vcs/git/git-1.7.4_rc1-r2.ebuild
+++ b/dev-vcs/git/git-1.7.4_rc1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.4_rc1-r2.ebuild,v 1.4 2011/01/08 14:11:18 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.4_rc1-r2.ebuild,v 1.5 2011/01/10 18:44:21 arfrever Exp $
EAPI=3
@@ -493,6 +493,7 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
+ use python && python_mod_optimize git_remote_helpers
if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
ewarn "You must build dev-vcs/subversion with USE=perl"
ewarn "to get the full functionality of git-svn!"
@@ -507,4 +508,5 @@ pkg_postinst() {
pkg_postrm() {
use emacs && elisp-site-regen
+ use python && python_mod_cleanup git_remote_helpers
}
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index ff10a1135cfc..0623a88e1ea1 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.15 2011/01/08 14:11:18 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.16 2011/01/10 18:44:21 arfrever Exp $
EAPI=3
@@ -493,6 +493,7 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
+ use python && python_mod_optimize git_remote_helpers
if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
ewarn "You must build dev-vcs/subversion with USE=perl"
ewarn "to get the full functionality of git-svn!"
@@ -507,4 +508,5 @@ pkg_postinst() {
pkg_postrm() {
use emacs && elisp-site-regen
+ use python && python_mod_cleanup git_remote_helpers
}