summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-25 04:41:42 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-25 04:41:42 +0000
commit3683ac24ec811f5e6a42e76be9662a40b1a5f16d (patch)
tree42d6eea5250446bd0e2dc15e3ed6b246180b52f8 /dev-vcs/git-bzr-ng
parentCorrecting sbcl workaround (#411453); dont load init file in ccl (#432246, th... (diff)
downloadgentoo-2-3683ac24ec811f5e6a42e76be9662a40b1a5f16d.tar.gz
gentoo-2-3683ac24ec811f5e6a42e76be9662a40b1a5f16d.tar.bz2
gentoo-2-3683ac24ec811f5e6a42e76be9662a40b1a5f16d.zip
New snapshot.
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/git-bzr-ng')
-rw-r--r--dev-vcs/git-bzr-ng/ChangeLog8
-rw-r--r--dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-vcs/git-bzr-ng/ChangeLog b/dev-vcs/git-bzr-ng/ChangeLog
index 2c47a307d895..baa02adfebed 100644
--- a/dev-vcs/git-bzr-ng/ChangeLog
+++ b/dev-vcs/git-bzr-ng/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git-bzr-ng
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-bzr-ng/ChangeLog,v 1.4 2012/08/11 09:30:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-bzr-ng/ChangeLog,v 1.5 2012/08/25 04:41:42 tetromino Exp $
+
+*git-bzr-ng-0_pre20120822 (25 Aug 2012)
+
+ 25 Aug 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +git-bzr-ng-0_pre20120822.ebuild:
+ New snapshot.
11 Aug 2012; Agostino Sarubbo <ago@gentoo.org>
git-bzr-ng-0_pre20120130.ebuild:
diff --git a/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822.ebuild b/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822.ebuild
new file mode 100644
index 000000000000..5e4c1a472d18
--- /dev/null
+++ b/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822.ebuild,v 1.1 2012/08/25 04:41:42 tetromino Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Git subcommand providing a bidirectional bridge to Bazaar repositories"
+HOMEPAGE="https://github.com/termie/git-bzr-ng"
+SRC_URI="http://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-vcs/bzr-2.2
+ dev-vcs/git
+ >=dev-vcs/bzr-fastimport-0.10
+ dev-python/python-fastimport"
+DEPEND="app-arch/xz-utils"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs 2 git-bzr
+}
+
+src_install() {
+ exeinto /usr/libexec/git-core
+ doexe git-bzr
+ dodoc README.rst
+}