summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-03-25 14:58:21 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-03-25 14:58:21 +0000
commit275e43895b0ce5f2d863f4fa2a163292a2810d31 (patch)
tree5f1361d0efd51115266114fe998c64d72b42d125 /dev-vcs/bzr
parentRaise gtk-doc{,-am} dependencies. Fixes bug 311085 (diff)
downloadgentoo-2-275e43895b0ce5f2d863f4fa2a163292a2810d31.tar.gz
gentoo-2-275e43895b0ce5f2d863f4fa2a163292a2810d31.tar.bz2
gentoo-2-275e43895b0ce5f2d863f4fa2a163292a2810d31.zip
version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'dev-vcs/bzr')
-rw-r--r--dev-vcs/bzr/ChangeLog10
-rw-r--r--dev-vcs/bzr/bzr-2.1.1.ebuild125
-rw-r--r--dev-vcs/bzr/files/bzr-2.1.1-no-pyrex-citon.patch33
3 files changed, 166 insertions, 2 deletions
diff --git a/dev-vcs/bzr/ChangeLog b/dev-vcs/bzr/ChangeLog
index 85dfe8cd04c1..de2629219c32 100644
--- a/dev-vcs/bzr/ChangeLog
+++ b/dev-vcs/bzr/ChangeLog
@@ -1,6 +1,12 @@
-# ChangeLog for dev-util/bzr
+# ChangeLog for dev-vcs/bzr
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.1 2010/03/05 09:33:53 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.2 2010/03/25 14:58:21 fauli Exp $
+
+*bzr-2.1.1 (25 Mar 2010)
+
+ 25 Mar 2010; Christian Faulhammer <fauli@gentoo.org> +bzr-2.1.1.ebuild,
+ +files/bzr-2.1.1-no-pyrex-citon.patch:
+ version bump
03 Mar 2010; Christian Faulhammer <fauli@gentoo.org> bzr-2.1.0.ebuild:
fix SRC_URI, thanks to Locke Shinseiko <Wizzleby AT gmail DOT com> in bug
diff --git a/dev-vcs/bzr/bzr-2.1.1.ebuild b/dev-vcs/bzr/bzr-2.1.1.ebuild
new file mode 100644
index 000000000000..9710b0afa952
--- /dev/null
+++ b/dev-vcs/bzr/bzr-2.1.1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.1.1.ebuild,v 1.1 2010/03/25 14:58:21 fauli Exp $
+
+EAPI=3
+
+PYTHON_DEPEND=2
+
+inherit bash-completion distutils elisp-common eutils versionator
+
+MY_P=${PN}-${PV}
+SERIES=$(get_version_component_range 1-2)
+
+DESCRIPTION="Bazaar is a next generation distributed version control system."
+HOMEPAGE="http://bazaar-vcs.org/"
+#SRC_URI="http://bazaar-vcs.org/releases/src/${MY_P}.tar.gz"
+SRC_URI="http://launchpad.net/bzr/${SERIES}/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
+IUSE="curl doc emacs +sftp test"
+
+# Disable until https://bugs.launchpad.net/bzr/+bug/392127 is fixed
+RESTRICT=test
+
+RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/celementtree )
+ curl? ( dev-python/pycurl )
+ sftp? ( dev-python/paramiko )"
+
+DEPEND="emacs? ( virtual/emacs )
+ test? (
+ $RDEPEND
+ dev-python/medusa
+ )"
+
+S="${WORKDIR}/${MY_P}"
+PYTHON_MODNAME="bzrlib"
+SITEFILE=71bzr-gentoo.el
+DOCS="doc/*.txt"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Don't regenerate .c files from .pyx when pyrex is found.
+ epatch "${FILESDIR}/${PN}-2.1.1-no-pyrex-citon.patch"
+ # Don't run lock permission tests when running as root
+ epatch "${FILESDIR}/${PN}-0.90-tests-fix_root.patch"
+ # Fix permission errors when run under directories with setgid set.
+ epatch "${FILESDIR}/${PN}-0.90-tests-sgid.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use emacs; then
+ elisp-compile contrib/emacs/bzr-mode.el || die
+ fi
+}
+
+src_install() {
+ distutils_src_install --install-data "${EPREFIX}"/usr/share
+
+ if use doc; then
+ docinto developers
+ dodoc doc/developers/* || die
+ for doc in mini-tutorial tutorials user-{guide,reference}; do
+ docinto $doc
+ dodoc doc/en/$doc/* || die
+ done
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} contrib/emacs/*.el* || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ # don't add automatically to the load-path, so the sitefile
+ # can do a conditional loading
+ touch "${ED}${SITELISP}/${PN}/.nosearch"
+ fi
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh/_bzr
+ dobashcompletion contrib/bash/bzr
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ bash-completion_pkg_postinst
+
+ if use emacs; then
+ elisp-site-regen
+ elog "If you are using a GNU Emacs version greater than 22.1, bzr support"
+ elog "is already included. This ebuild does not automatically activate bzr support"
+ elog "in versions below, but prepares it in a way you can load it from your ~/.emacs"
+ elog "file by adding"
+ elog " (load \"bzr-mode\")"
+ fi
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}
+
+src_test() {
+ export LC_ALL=C
+ # Define tests which are known to fail below.
+ local skip_tests="("
+ #https://bugs.launchpad.net/bzr/+bug/456471
+ skip_tests+="bzrlib.tests.blackbox.test_version.*|"
+ # https://bugs.launchpad.net/bzr/+bug/392127
+ skip_tests+="test_http.*"
+ skip_tests+=")"
+ # Some tests expect the usual pyc compiling behaviour.
+ python_enable_pyc
+ if [[ -n ${skip_tests} ]]; then
+ einfo "Skipping tests known to fail: ${skip_tests}"
+ "$(PYTHON -A)" bzr --no-plugins selftest -x ${skip_tests} || die
+ else
+ "$(PYTHON -A)" bzr --no-plugins selftest || die
+ fi
+ # Just to make sure we don't hit any errors on later stages.
+ python_disable_pyc
+}
diff --git a/dev-vcs/bzr/files/bzr-2.1.1-no-pyrex-citon.patch b/dev-vcs/bzr/files/bzr-2.1.1-no-pyrex-citon.patch
new file mode 100644
index 000000000000..02d6d833c2c3
--- /dev/null
+++ b/dev-vcs/bzr/files/bzr-2.1.1-no-pyrex-citon.patch
@@ -0,0 +1,33 @@
+--- setup.py.orig 2010-03-25 15:54:31.031989804 +0100
++++ setup.py 2010-03-25 15:55:24.943965524 +0100
+@@ -166,27 +166,9 @@
+ from distutils.errors import CCompilerError, DistutilsPlatformError
+ from distutils.extension import Extension
+ ext_modules = []
+-try:
+- try:
+- from Pyrex.Distutils import build_ext
+- from Pyrex.Compiler.Version import version as pyrex_version
+- except ImportError:
+- print "No Pyrex, trying Cython..."
+- from Cython.Distutils import build_ext
+- from Cython.Compiler.Version import version as pyrex_version
+-except ImportError:
+- have_pyrex = False
+- # try to build the extension from the prior generated source.
+- print
+- print ("The python package 'Pyrex' is not available."
+- " If the .c files are available,")
+- print ("they will be built,"
+- " but modifying the .pyx files will not rebuild them.")
+- print
+- from distutils.command.build_ext import build_ext
+-else:
+- have_pyrex = True
+- pyrex_version_info = tuple(map(int, pyrex_version.split('.')))
++
++have_pyrex = False
++from distutils.command.build_ext import build_ext
+
+
+ class build_ext_if_possible(build_ext):