summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-02-12 01:27:31 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-02-12 01:27:31 +0000
commitd4001db90fd548f7403f760f0c999198f9cd3d22 (patch)
tree99ced424c901f262dee37420b1840ad44f5f5a1a /dev-util
parentMigrate to distutils-r1. Fix tests when TMPDIR != /tmp. (diff)
downloadgentoo-2-d4001db90fd548f7403f760f0c999198f9cd3d22.tar.gz
gentoo-2-d4001db90fd548f7403f760f0c999198f9cd3d22.tar.bz2
gentoo-2-d4001db90fd548f7403f760f0c999198f9cd3d22.zip
Respect CFLAGS, bug #455440
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/plan9port/ChangeLog9
-rw-r--r--dev-util/plan9port/files/plan9port-cflags.patch16
-rw-r--r--dev-util/plan9port/plan9port-20130209-r1.ebuild (renamed from dev-util/plan9port/plan9port-20130209.ebuild)4
3 files changed, 26 insertions, 3 deletions
diff --git a/dev-util/plan9port/ChangeLog b/dev-util/plan9port/ChangeLog
index 59b2899543dd..c6b8fe4c62f8 100644
--- a/dev-util/plan9port/ChangeLog
+++ b/dev-util/plan9port/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/plan9port
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/ChangeLog,v 1.11 2013/02/11 00:26:30 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/ChangeLog,v 1.12 2013/02/12 01:27:31 blueness Exp $
+
+*plan9port-20130209-r1 (12 Feb 2013)
+
+ 12 Feb 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/plan9port-cflags.patch, +plan9port-20130209-r1.ebuild,
+ -plan9port-20130209.ebuild:
+ Respect CFLAGS, bug #455440
*plan9port-20130209 (11 Feb 2013)
diff --git a/dev-util/plan9port/files/plan9port-cflags.patch b/dev-util/plan9port/files/plan9port-cflags.patch
new file mode 100644
index 000000000000..c2d2ed6defe5
--- /dev/null
+++ b/dev-util/plan9port/files/plan9port-cflags.patch
@@ -0,0 +1,16 @@
+Prevent resetting CFLAGS and LDFLAGS
+
+This allows the plan9port build to inherit cflags from the environment.
+
+(This patch must be applied after plan9port-noexecstack.patch)
+--- a/src/mkhdr
++++ b/src/mkhdr
+@@ -28,8 +28,6 @@ LD=9l
+ AS=9a
+ AR=9ar
+ INSTALL=install
+-CFLAGS=
+-LDFLAGS=
+ AFLAGS=--noexecstack
+ CLEANFILES=
+ NUKEFILES=
diff --git a/dev-util/plan9port/plan9port-20130209.ebuild b/dev-util/plan9port/plan9port-20130209-r1.ebuild
index ed6cc8153a5c..5d456f73b453 100644
--- a/dev-util/plan9port/plan9port-20130209.ebuild
+++ b/dev-util/plan9port/plan9port-20130209-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/plan9port-20130209.ebuild,v 1.1 2013/02/11 00:26:30 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/plan9port-20130209-r1.ebuild,v 1.1 2013/02/12 01:27:31 blueness Exp $
EAPI="4"
@@ -24,7 +24,7 @@ PLAN9=/usr/lib/plan9
src_prepare()
{
- epatch "${FILESDIR}/${PN}-"{9660srv-errno,noexecstack}".patch"
+ epatch "${FILESDIR}/${PN}-"{9660srv-errno,noexecstack,cflags}".patch"
# Fix paths, done in place of ./INSTALL -c
einfo "Fixing hard-coded /usr/local/plan9 paths"