summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2014-02-01 16:18:05 +0000
committerFabian Groffen <grobian@gentoo.org>2014-02-01 16:18:05 +0000
commitbce4c324e2981b768236aaf805d00063e21c8427 (patch)
tree35974f82e1c7a0f439e7388329a754aa47e4a58a /dev-util
parentVersion bump, bug 99976 (diff)
downloadgentoo-2-bce4c324e2981b768236aaf805d00063e21c8427.tar.gz
gentoo-2-bce4c324e2981b768236aaf805d00063e21c8427.tar.bz2
gentoo-2-bce4c324e2981b768236aaf805d00063e21c8427.zip
Fix glib build on some Prefix platforms with USE=internal-glib during bootstrap
(Portage version: 2.2.8-prefix/cvs/SunOS i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgconfig/ChangeLog7
-rw-r--r--dev-util/pkgconfig/pkgconfig-0.28.ebuild13
-rw-r--r--dev-util/pkgconfig/pkgconfig-9999.ebuild13
3 files changed, 28 insertions, 5 deletions
diff --git a/dev-util/pkgconfig/ChangeLog b/dev-util/pkgconfig/ChangeLog
index dae2cca1304b..a3c8102470c1 100644
--- a/dev-util/pkgconfig/ChangeLog
+++ b/dev-util/pkgconfig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/pkgconfig
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.141 2014/01/18 04:44:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.142 2014/02/01 16:18:05 grobian Exp $
+
+ 01 Feb 2014; Fabian Groffen <grobian@gentoo.org> pkgconfig-0.28.ebuild,
+ pkgconfig-9999.ebuild:
+ Fix glib build on some Prefix platforms with USE=internal-glib during
+ bootstrap
18 Jan 2014; Mike Frysinger <vapier@gentoo.org> pkgconfig-0.28.ebuild,
pkgconfig-9999.ebuild:
diff --git a/dev-util/pkgconfig/pkgconfig-0.28.ebuild b/dev-util/pkgconfig/pkgconfig-0.28.ebuild
index 2392c6caaf76..57a62f4a4b2d 100644
--- a/dev-util/pkgconfig/pkgconfig-0.28.ebuild
+++ b/dev-util/pkgconfig/pkgconfig-0.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.28.ebuild,v 1.14 2014/01/18 04:44:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.28.ebuild,v 1.15 2014/02/01 16:18:05 grobian Exp $
EAPI=5
@@ -21,7 +21,7 @@ HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="elibc_FreeBSD hardened internal-glib"
+IUSE="elibc_FreeBSD elibc_glibc hardened internal-glib"
RDEPEND="!internal-glib? ( >=dev-libs/glib-2.30 )
!dev-util/pkgconf[pkg-config]
@@ -48,6 +48,15 @@ src_configure() {
if use internal-glib; then
myconf+=' --with-internal-glib'
+ # non-glibc platforms use GNU libiconv, but configure needs to
+ # know about that not to get confused when it finds something
+ # outside the prefix too
+ if use prefix && use !elibc_glibc ; then
+ myconf+=" --with-libiconv=gnu"
+ # add the libdir for libtool, otherwise it'll make love with system
+ # installed libiconv
+ append-ldflags "-L${EPREFIX}/usr/$(get_libdir)"
+ fi
else
if ! has_version dev-util/pkgconfig; then
export GLIB_CFLAGS="-I${EPREFIX}/usr/include/glib-2.0 -I${EPREFIX}/usr/$(get_libdir)/glib-2.0/include"
diff --git a/dev-util/pkgconfig/pkgconfig-9999.ebuild b/dev-util/pkgconfig/pkgconfig-9999.ebuild
index 4c072e0c1531..66fe041389b4 100644
--- a/dev-util/pkgconfig/pkgconfig-9999.ebuild
+++ b/dev-util/pkgconfig/pkgconfig-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-9999.ebuild,v 1.9 2014/01/18 04:44:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-9999.ebuild,v 1.10 2014/02/01 16:18:05 grobian Exp $
EAPI=5
@@ -21,7 +21,7 @@ HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="elibc_FreeBSD hardened internal-glib"
+IUSE="elibc_FreeBSD elibc_glibc hardened internal-glib"
RDEPEND="!internal-glib? ( >=dev-libs/glib-2.30 )
!dev-util/pkgconf[pkg-config]
@@ -48,6 +48,15 @@ src_configure() {
if use internal-glib; then
myconf+=' --with-internal-glib'
+ # non-glibc platforms use GNU libiconv, but configure needs to
+ # know about that not to get confused when it finds something
+ # outside the prefix too
+ if use prefix && use !elibc_glibc ; then
+ myconf+=" --with-libiconv=gnu"
+ # add the libdir for libtool, otherwise it'll make love with system
+ # installed libiconv
+ append-ldflags "-L${EPREFIX}/usr/$(get_libdir)"
+ fi
else
if ! has_version dev-util/pkgconfig; then
export GLIB_CFLAGS="-I${EPREFIX}/usr/include/glib-2.0 -I${EPREFIX}/usr/$(get_libdir)/glib-2.0/include"