summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-07 11:21:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-07 11:21:55 +0000
commitb3bcfdd1b144f40e062e930a43b56af5dc7a77ee (patch)
treeae92936004a473193151f9552c9d5228aab00014 /dev-util
parentMoved to EAPI=3 for PREFIX support, keyworded for *-linux, tested by me (diff)
downloadgentoo-2-b3bcfdd1b144f40e062e930a43b56af5dc7a77ee.tar.gz
gentoo-2-b3bcfdd1b144f40e062e930a43b56af5dc7a77ee.tar.bz2
gentoo-2-b3bcfdd1b144f40e062e930a43b56af5dc7a77ee.zip
Version bump.
(Portage version: 15754-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/global/ChangeLog8
-rw-r--r--dev-util/global/global-5.8.1.ebuild68
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index 0658bb8aa800..b5350da556cc 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/global
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.47 2010/02/20 20:13:32 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.48 2010/03/07 11:21:55 arfrever Exp $
+
+*global-5.8.1 (07 Mar 2010)
+
+ 07 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +global-5.8.1.ebuild:
+ Version bump.
*global-5.8 (20 Feb 2010)
diff --git a/dev-util/global/global-5.8.1.ebuild b/dev-util/global/global-5.8.1.ebuild
new file mode 100644
index 000000000000..4374eefa1354
--- /dev/null
+++ b/dev-util/global/global-5.8.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-5.8.1.ebuild,v 1.1 2010/03/07 11:21:55 arfrever Exp $
+
+EAPI="3"
+
+inherit elisp-common
+
+DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in various sources."
+HOMEPAGE="http://www.gnu.org/software/global/global.html"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc vim emacs"
+
+RDEPEND="vim? ( || ( app-editors/vim app-editors/gvim ) )
+ emacs? ( virtual/emacs )"
+DEPEND="${DEPEND}
+ doc? ( app-text/texi2html sys-apps/texinfo )"
+
+SITEFILE="50gtags-gentoo.el"
+
+src_compile() {
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.texi
+ texi2html -o doc/global.html doc/global.texi
+ fi
+
+ if use emacs; then
+ elisp-compile *.el || die "elisp-compile failed"
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use doc; then
+ dohtml doc/global.html
+ [[ -f doc/global.pdf ]] && dodoc doc/global.pdf
+ fi
+ dodoc AUTHORS FAQ NEWS README THANKS
+
+ insinto /etc
+ doins gtags.conf
+ insinto /usr/share/${PN}
+ doins gtags.pl globash.rc
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install gtags *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}