summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2007-05-07 20:01:23 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2007-05-07 20:01:23 +0000
commita8b34f472a3e17548d279197c91ba45213669338 (patch)
tree2f4063e13014fc5abe122f34c7cdbdd9c2ca90eb /dev-util
parentBetter reflect reality for sparc profiles (diff)
downloadgentoo-2-a8b34f472a3e17548d279197c91ba45213669338.tar.gz
gentoo-2-a8b34f472a3e17548d279197c91ba45213669338.tar.bz2
gentoo-2-a8b34f472a3e17548d279197c91ba45213669338.zip
New upstream version.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bouml/ChangeLog7
-rw-r--r--dev-util/bouml/bouml-2.25.2.ebuild33
-rw-r--r--dev-util/bouml/files/digest-bouml-2.25.23
3 files changed, 42 insertions, 1 deletions
diff --git a/dev-util/bouml/ChangeLog b/dev-util/bouml/ChangeLog
index 487a6a52078f..e0cd3ac73437 100644
--- a/dev-util/bouml/ChangeLog
+++ b/dev-util/bouml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/bouml
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.26 2007/04/19 18:22:28 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.27 2007/05/07 20:01:23 ferdy Exp $
+
+*bouml-2.25.2 (07 May 2007)
+
+ 07 May 2007; Fernando J. Pereda <ferdy@gentoo.org> +bouml-2.25.2.ebuild:
+ New upstream version.
*bouml-2.24 (19 Apr 2007)
diff --git a/dev-util/bouml/bouml-2.25.2.ebuild b/dev-util/bouml/bouml-2.25.2.ebuild
new file mode 100644
index 000000000000..7450f284e410
--- /dev/null
+++ b/dev-util/bouml/bouml-2.25.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-2.25.2.ebuild,v 1.1 2007/05/07 20:01:23 ferdy Exp $
+
+inherit qt3 toolchain-funcs multilib eutils
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool box with C++, Java and Idl code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(qt_min_version 3)"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake QMAKE="${QTDIR}/bin/qmake" \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ LINK="$(tc-getCXX) ${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/dev-util/bouml/files/digest-bouml-2.25.2 b/dev-util/bouml/files/digest-bouml-2.25.2
new file mode 100644
index 000000000000..8ac6cd1bf158
--- /dev/null
+++ b/dev-util/bouml/files/digest-bouml-2.25.2
@@ -0,0 +1,3 @@
+MD5 fbf9e1a20a75304ed61a5a14788d2010 bouml_2.25.2.tar.gz 3809609
+RMD160 ff22f867996b00b8d0d68257b2d0182db61192ef bouml_2.25.2.tar.gz 3809609
+SHA256 40d647d75e50ba042144aece0de69bc70708e6aba762c051f62d7a4fa39f6526 bouml_2.25.2.tar.gz 3809609