summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-04-24 06:46:18 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-04-24 06:46:18 +0000
commit88cc88b9b8d2881801821ae783825813d912ef79 (patch)
tree97ceee7e459f46d67a96bc3115515a3ecabe95d1 /dev-util
parentVersion bump (diff)
downloadgentoo-2-88cc88b9b8d2881801821ae783825813d912ef79.tar.gz
gentoo-2-88cc88b9b8d2881801821ae783825813d912ef79.tar.bz2
gentoo-2-88cc88b9b8d2881801821ae783825813d912ef79.zip
Version bump wrt #466198 by David Hallas <david@cgp.dk>. Drop old
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/astyle/ChangeLog13
-rw-r--r--dev-util/astyle/astyle-1.22.ebuild72
-rw-r--r--dev-util/astyle/astyle-1.24.ebuild45
-rw-r--r--dev-util/astyle/astyle-2.03.ebuild71
-rw-r--r--dev-util/astyle/files/astyle-1.22-Makefile.patch63
-rw-r--r--dev-util/astyle/metadata.xml5
6 files changed, 82 insertions, 187 deletions
diff --git a/dev-util/astyle/ChangeLog b/dev-util/astyle/ChangeLog
index 9ab47a9330ae..7b09c91c7693 100644
--- a/dev-util/astyle/ChangeLog
+++ b/dev-util/astyle/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/astyle
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.46 2012/10/07 08:58:26 pacho Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.47 2013/04/24 06:46:17 xarthisius Exp $
+
+*astyle-2.03 (24 Apr 2013)
+
+ 24 Apr 2013; Kacper Kowalik <xarthisius@gentoo.org> +astyle-2.03.ebuild,
+ -astyle-1.22.ebuild, -astyle-1.24.ebuild, -files/astyle-1.22-Makefile.patch,
+ metadata.xml:
+ Version bump wrt #466198 by David Hallas <david@cgp.dk>. Drop old
07 Oct 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, #24135.
@@ -112,7 +119,7 @@
Dropped ppc-macos keyword, see you in prefix
14 Nov 2007; Robin H. Johnson <robbat2@gentoo.org> astyle-1.21.ebuild:
- Fix $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.46 2012/10/07 08:58:26 pacho Exp $ string.
+ Fix $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.47 2013/04/24 06:46:17 xarthisius Exp $ string.
*astyle-1.21 (07 Oct 2007)
diff --git a/dev-util/astyle/astyle-1.22.ebuild b/dev-util/astyle/astyle-1.22.ebuild
deleted file mode 100644
index 83ce6ce184be..000000000000
--- a/dev-util/astyle/astyle-1.22.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-1.22.ebuild,v 1.14 2012/07/29 16:56:41 armin76 Exp $
-
-inherit eutils java-pkg-opt-2 multilib toolchain-funcs
-
-DESCRIPTION="Artistic Style is a reindenter and reformatter of C++, C and Java source code"
-HOMEPAGE="http://astyle.sourceforge.net/"
-SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86"
-
-IUSE="debug java libs"
-
-RDEPEND="java? ( >=virtual/jdk-1.6 )"
-
-DEPEND="java? ( >=virtual/jdk-1.6 )"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # Add basic soname to make QA happy...
- sed -i -e "s:-shared:-shared -Wl,-soname,\$@ :g" buildgcc/Makefile
- # Fix JAVA_HOME
- sed -i -e \
- "s:/usr/lib/jvm/java-6-sun-1.6.0.00:$(java-config --jdk-home):g" \
- buildgcc/Makefile || die "sed failed"
- # respect CFLAGS, remove strip and other hard-coded crap
- epatch "${FILESDIR}"/${P}-Makefile.patch
-}
-
-src_compile() {
- cd buildgcc
-
- emake CXX="$(tc-getCXX)" all $(use java && echo javaall) \
- || die "build failed"
-}
-
-src_install() {
- if use debug ; then
- newbin bin/astyled astyle || die "install debug bin failed"
- newlib.a bin/libastyled.a libastyle.a \
- || die "install debug static lib failed"
- if use libs ; then
- newlib.so bin/libastyled.so libastyle.so \
- || die "install debug shared lib failed"
- if use java ; then
- local j_dir="/usr/$(get_libdir)"
- dolib.so bin/libastylejd.so \
- || die "install debug shared java lib failed"
- java-pkg_regso "${D}${j_dir}/libastylejd.so"
- fi
- fi
- else
- if use libs ; then
- dolib.so bin/libastyle.so || die "install shared lib failed"
- if use java ; then
- local j_dir="/usr/$(get_libdir)"
- dolib.so bin/libastylej.so \
- || die "install shared java lib failed"
- java-pkg_regso "${D}${j_dir}/libastylej.so"
- fi
- fi
- dobin bin/astyle || die "install bin failed"
- dolib.a bin/libastyle.a || die "install static lib failed"
- fi
- dohtml doc/*.html
-}
diff --git a/dev-util/astyle/astyle-1.24.ebuild b/dev-util/astyle/astyle-1.24.ebuild
deleted file mode 100644
index c067f4720d96..000000000000
--- a/dev-util/astyle/astyle-1.24.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-1.24.ebuild,v 1.3 2012/07/29 16:56:41 armin76 Exp $
-
-EAPI=3
-
-inherit base java-pkg-opt-2 autotools
-
-DESCRIPTION="Artistic Style is a reindenter and reformatter of C++, C and Java source code"
-HOMEPAGE="http://astyle.sourceforge.net/"
-SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz
- http://gentoo.ccss.cz/${PV}-autotools.patch.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-IUSE="debug java"
-
-DEPEND="java? ( >=virtual/jdk-1.6 )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- java-pkg-opt-2_src_prepare
- cd "${WORKDIR}"
- epatch "${PV}-autotools.patch"
- cd "${S}"
-
- eautoreconf
-}
-
-src_configure() {
- local myopts
- if use java; then
- myopts="--with-java-include-dir=${JAVA_HOME}/include/"
- fi
-
- econf \
- --disable-dependency-tracking \
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html/ \
- $(use_enable debug) \
- ${myopts}
-}
diff --git a/dev-util/astyle/astyle-2.03.ebuild b/dev-util/astyle/astyle-2.03.ebuild
new file mode 100644
index 000000000000..e6e8479c3631
--- /dev/null
+++ b/dev-util/astyle/astyle-2.03.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-2.03.ebuild,v 1.1 2013/04/24 06:46:17 xarthisius Exp $
+
+EAPI=4
+
+inherit eutils java-pkg-opt-2 multilib toolchain-funcs
+
+DESCRIPTION="Artistic Style is a reindenter and reformatter of C++, C and Java source code"
+HOMEPAGE="http://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+IUSE="doc java static-libs"
+
+DEPEND="app-arch/xz-utils
+ java? ( >=virtual/jdk-1.6 )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+ tc-export CXX
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.02.1-build_system.patch
+ java-pkg-opt-2_src_prepare
+ sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
+ -e "s:ar crs:$(tc-getAR) crs:" \
+ -i build/gcc/Makefile || die
+}
+
+src_compile() {
+ local mk_opts="-f ../build/gcc/Makefile -C src"
+ emake ${mk_opts} ${PN}
+ emake ${mk_opts} shared
+ if use java ; then
+ emake ${mk_opts} java
+ fi
+ if use static-libs ; then
+ emake ${mk_opts} static
+ fi
+}
+
+src_install() {
+ insinto /usr/include
+ doins src/${PN}.h
+
+ pushd src/bin &> /dev/null
+ dobin ${PN}
+
+ dolib.so lib${PN}.so.0.0.0
+ dosym lib${PN}.so.0.0.0 /usr/$(get_libdir)/lib${PN}.so.0
+ dosym lib${PN}.so.0.0.0 /usr/$(get_libdir)/lib${PN}.so
+ if use java ; then
+ dolib.so lib${PN}j.so.0.0.0
+ dosym lib${PN}j.so.0.0.0 /usr/$(get_libdir)/lib${PN}j.so.0
+ dosym lib${PN}j.so.0.0.0 /usr/$(get_libdir)/lib${PN}j.so
+ fi
+ if use static-libs ; then
+ dolib lib${PN}.a
+ fi
+ popd &> /dev/null
+
+ use doc && dohtml doc/*
+}
diff --git a/dev-util/astyle/files/astyle-1.22-Makefile.patch b/dev-util/astyle/files/astyle-1.22-Makefile.patch
deleted file mode 100644
index 44779a28b0cf..000000000000
--- a/dev-util/astyle/files/astyle-1.22-Makefile.patch
+++ /dev/null
@@ -1,63 +0,0 @@
---- buildgcc/Makefile.orig 2008-10-14 20:31:23.645424162 -0700
-+++ buildgcc/Makefile 2008-10-14 20:36:36.484423984 -0700
-@@ -36,14 +36,14 @@
- ##################################################
-
- # define compile options for each build
--CFLAGS = -DNDEBUG -O3 $(CBASEFLAGS)
--CFLAGSd = -g $(CBASEFLAGS)
--CFLAGSs = -DNDEBUG -DASTYLE_LIB -O3 -fpic $(CBASEFLAGS)
--CFLAGSsd = -DASTYLE_LIB -g -fpic $(CBASEFLAGS)
--CFLAGSa = -DNDEBUG -DASTYLE_LIB -O3 $(CBASEFLAGS)
--CFLAGSad = -DASTYLE_LIB -g $(CBASEFLAGS)
--CFLAGSsj = -DNDEBUG -DASTYLE_JNI -O3 -fpic $(CBASEFLAGS) $(JAVAINCS)
--CFLAGSsjd = -DASTYLE_JNI -g -fpic $(CBASEFLAGS) $(JAVAINCS)
-+CFLAGSb = -DNDEBUG $(CFLAGS)
-+CFLAGSd = -g $(CFLAGS)
-+CFLAGSs = -DNDEBUG -DASTYLE_LIB -fPIC $(CFLAGS)
-+CFLAGSsd = -DASTYLE_LIB -g -fPIC $(CFLAGS)
-+CFLAGSa = -DNDEBUG -DASTYLE_LIB $(CFLAGS)
-+CFLAGSad = -DASTYLE_LIB -g $(CFLAGS)
-+CFLAGSsj = -DNDEBUG -DASTYLE_JNI -fPIC $(CFLAGS) $(JAVAINCS)
-+CFLAGSsjd = -DASTYLE_JNI -g -fPIC $(CFLAGS) $(JAVAINCS)
-
- # object files are built from the source list $(SRC)
- # a suffix is added for each build
-@@ -61,7 +61,7 @@
- # OBJ
- $(objdir)/%.o: %.cpp astyle.h
- @ mkdir -p $(objdir)
-- $(CXX) $(CFLAGS) -c -o $@ $<
-+ $(CXX) $(CFLAGSb) -c -o $@ $<
-
- # OBJd
- $(objdir)/%_d.o: %.cpp astyle.h
-@@ -104,7 +104,7 @@
- release: astyle
- astyle: $(OBJ)
- @ mkdir -p $(bindir)
-- $(CXX) -s -o $(bindir)/$@ $^
-+ $(CXX) -o $(bindir)/$@ $^
- @ echo
-
- debug: astyled
-@@ -116,7 +116,7 @@
- shared: libastyle.so
- libastyle.so: $(OBJs)
- @ mkdir -p $(bindir)
-- $(CXX) -shared -Wl,-soname,$@ -s -o $(bindir)/$@ $^
-+ $(CXX) -shared -Wl,-soname,$@ -o $(bindir)/$@ $^
- @ echo
-
- shareddebug: libastyled.so
---- buildgcc/Makefile.orig 2008-11-10 18:00:51.462464681 -0800
-+++ buildgcc/Makefile 2008-11-10 18:31:21.586465413 -0800
-@@ -140,7 +140,7 @@
- java: libastylej.so
- libastylej.so: $(OBJsj)
- @ mkdir -p $(bindir)
-- $(CXX) -shared -Wl,-soname,$@ -s -o $(bindir)/$@ $^
-+ $(CXX) -shared -Wl,-soname,$@ -o $(bindir)/$@ $^
- @ echo
-
- javadebug: libastylejd.so
diff --git a/dev-util/astyle/metadata.xml b/dev-util/astyle/metadata.xml
index 9279c323d62d..a38af152191e 100644
--- a/dev-util/astyle/metadata.xml
+++ b/dev-util/astyle/metadata.xml
@@ -29,8 +29,5 @@
written in C++, that automatically reindent &amp; reformat C/C++/Java source
files. These can be used from a command line, or it can be incorporated as
classes in another C++ program.
-</longdescription>
- <use>
- <flag name="libs">builds and installs both shared and static library interfaces</flag>
- </use>
+ </longdescription>
</pkgmetadata>