summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-05-07 21:28:31 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-05-07 21:28:31 +0000
commit65814f472b85f0d65dba4915a91da7a371d02c41 (patch)
tree8a3193df68f06be59b14e07678e47b6e6e06c02d /dev-util
parentversion bump (diff)
downloadgentoo-2-65814f472b85f0d65dba4915a91da7a371d02c41.tar.gz
gentoo-2-65814f472b85f0d65dba4915a91da7a371d02c41.tar.bz2
gentoo-2-65814f472b85f0d65dba4915a91da7a371d02c41.zip
Version bump. Thanks to everyone in bug #126615.
(Portage version: 2.1.2.5)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/svn2cl/ChangeLog8
-rw-r--r--dev-util/svn2cl/files/0.9-wrapper.patch20
-rw-r--r--dev-util/svn2cl/files/digest-svn2cl-0.93
-rw-r--r--dev-util/svn2cl/svn2cl-0.9.ebuild38
4 files changed, 68 insertions, 1 deletions
diff --git a/dev-util/svn2cl/ChangeLog b/dev-util/svn2cl/ChangeLog
index 0e2518ed63ba..6ad036d91901 100644
--- a/dev-util/svn2cl/ChangeLog
+++ b/dev-util/svn2cl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/svn2cl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/svn2cl/ChangeLog,v 1.3 2007/03/19 02:24:01 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/svn2cl/ChangeLog,v 1.4 2007/05/07 21:28:31 betelgeuse Exp $
+
+*svn2cl-0.9 (07 May 2007)
+
+ 07 May 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +files/0.9-wrapper.patch, +svn2cl-0.9.ebuild:
+ Version bump. Thanks to everyone in bug #126615.
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove ka0ttic from metadata.xml due to retirement.
diff --git a/dev-util/svn2cl/files/0.9-wrapper.patch b/dev-util/svn2cl/files/0.9-wrapper.patch
new file mode 100644
index 000000000000..478b2a032d2a
--- /dev/null
+++ b/dev-util/svn2cl/files/0.9-wrapper.patch
@@ -0,0 +1,20 @@
+--- svn2cl.sh 2006-10-18 23:38:06.000000000 +0200
++++ svn2cl.sh.1 2006-11-12 01:41:05.000000000 +0100
+@@ -234,16 +234,7 @@
+ esac
+ done
+
+-# find the directory that this script resides in
+-prog="$0"
+-while [ -h "$prog" ]
+-do
+- dir=`dirname "$prog"`
+- prog=`ls -ld "$prog" | sed "s/^.*-> \(.*\)/\1/;/^[^/]/s,^,$dir/,"`
+-done
+-dir=`dirname "$prog"`
+-dir=`cd "$dir" && pwd`
+-XSL="$dir/svn2${OUTSTYLE}.xsl"
++XSL="/usr/share/svn2cl/svn2${OUTSTYLE}.xsl"
+
+ # check if the authors file is formatted as a legacy
+ # colon separated file
diff --git a/dev-util/svn2cl/files/digest-svn2cl-0.9 b/dev-util/svn2cl/files/digest-svn2cl-0.9
new file mode 100644
index 000000000000..bb21090c0479
--- /dev/null
+++ b/dev-util/svn2cl/files/digest-svn2cl-0.9
@@ -0,0 +1,3 @@
+MD5 0414dc0f18b424b03727dfad6fa9e63d svn2cl-0.9.tar.gz 16725
+RMD160 549a729e58720cb32f17fa65d04a94dbd3fef1fe svn2cl-0.9.tar.gz 16725
+SHA256 582ff45a859de83c8cc4f7c6196ec02968fcc96c91de864dcd22838c210f5f7c svn2cl-0.9.tar.gz 16725
diff --git a/dev-util/svn2cl/svn2cl-0.9.ebuild b/dev-util/svn2cl/svn2cl-0.9.ebuild
new file mode 100644
index 000000000000..f3a3c871a68c
--- /dev/null
+++ b/dev-util/svn2cl/svn2cl-0.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/svn2cl/svn2cl-0.9.ebuild,v 1.1 2007/05/07 21:28:31 betelgeuse Exp $
+
+inherit eutils
+
+DESCRIPTION="Create a GNU-style ChangeLog from subversion's svn log --xml output."
+HOMEPAGE="http://ch.tudelft.nl/~arthur/svn2cl/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxslt
+ dev-util/subversion"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # the wrapper script looks for the xsl files in the
+ # same directory as the script.
+ epatch ${FILESDIR}/0.9-wrapper.patch
+}
+
+src_install() {
+ newbin svn2cl.sh svn2cl || die "failed to install wrapper script"
+ insinto /usr/share/svn2cl
+ doins svn2cl.xsl svn2html.xsl || die
+ dodoc README NEWS TODO ChangeLog authors.xml svn2html.css || die
+ doman svn2cl.1 || die
+}
+pkg_postinst() {
+ einfo "You can find samples of svn2html.css and authors.xml in"
+ einfo "/usr/share/doc/${PF}/"
+ einfo "Read man page for details."
+}