summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-23 15:50:42 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-10-23 15:50:42 +0000
commit61ae993b77d80b175b0dfd1598c602540b9f029e (patch)
tree422f698f544c4a1d392fbd1cffb9b2ef0c9411e7 /dev-util
parentVersion bump, fixes bugs 429960, 437986, 438112. Remove old. (diff)
downloadgentoo-2-61ae993b77d80b175b0dfd1598c602540b9f029e.tar.gz
gentoo-2-61ae993b77d80b175b0dfd1598c602540b9f029e.tar.bz2
gentoo-2-61ae993b77d80b175b0dfd1598c602540b9f029e.zip
version bump
(Portage version: 2.2.0_alpha141/cvs/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ninja/ChangeLog8
-rw-r--r--dev-util/ninja/metadata.xml3
-rw-r--r--dev-util/ninja/ninja-1.0.0.ebuild (renamed from dev-util/ninja/ninja-120715.ebuild)17
-rw-r--r--dev-util/ninja/ninja-120508.ebuild88
4 files changed, 21 insertions, 95 deletions
diff --git a/dev-util/ninja/ChangeLog b/dev-util/ninja/ChangeLog
index 6243f5bf1401..c5938f1bfb2d 100644
--- a/dev-util/ninja/ChangeLog
+++ b/dev-util/ninja/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/ninja
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ChangeLog,v 1.3 2012/08/25 14:17:27 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ChangeLog,v 1.4 2012/10/23 15:50:41 ottxor Exp $
+
+*ninja-1.0.0 (23 Oct 2012)
+
+ 23 Oct 2012; Christoph Junghans <ottxor@gentoo.org> +ninja-1.0.0.ebuild,
+ -ninja-120508.ebuild, -ninja-120715.ebuild, metadata.xml:
+ version bump
25 Aug 2012; Christoph Junghans <ottxor@gentoo.org> ninja-120715.ebuild:
added ~ppc-macos (bug #432692)
diff --git a/dev-util/ninja/metadata.xml b/dev-util/ninja/metadata.xml
index 745b9e1ce74b..49598cfb05b7 100644
--- a/dev-util/ninja/metadata.xml
+++ b/dev-util/ninja/metadata.xml
@@ -5,4 +5,7 @@
<email>ottxor@gentoo.org</email>
<name>Christoph Junghans</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">martine/ninja</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-util/ninja/ninja-120715.ebuild b/dev-util/ninja/ninja-1.0.0.ebuild
index 745772b176d2..21643bf6e9d4 100644
--- a/dev-util/ninja/ninja-120715.ebuild
+++ b/dev-util/ninja/ninja-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ninja-120715.ebuild,v 1.2 2012/08/25 14:17:27 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ninja-1.0.0.ebuild,v 1.1 2012/10/23 15:50:41 ottxor Exp $
EAPI=4
@@ -14,7 +14,7 @@ if [ "${PV}" = "999999" ]; then
KEYWORDS=""
else
inherit vcs-snapshot
- SRC_URI="https://github.com/martine/ninja/tarball/release-${PV} -> ${P}.tar.gz"
+ SRC_URI="https://github.com/martine/ninja/tarball/v${PV} -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~ppc-macos"
fi
@@ -26,15 +26,20 @@ SLOT="0"
IUSE="doc emacs vim-syntax zsh-completion"
-DEPEND="doc? ( app-text/asciidoc app-doc/doxygen )"
-RDEPEND="zsh-completion? ( app-shells/zsh )
+DEPEND="
+ dev-util/re2c
+ doc? ( app-text/asciidoc app-doc/doxygen )
+ "
+RDEPEND="
emacs? ( virtual/emacs )
vim-syntax? (
|| (
app-editors/vim
app-editors/gvim
)
- )"
+ )
+ zsh-completion? ( app-shells/zsh )
+ "
pkg_setup() {
python_set_active_version 2
@@ -53,7 +58,7 @@ src_compile() {
}
src_install() {
- dodoc README HACKING
+ dodoc README HACKING.md
use doc && dohtml -r doc/doxygen/html/*
dobin ninja
diff --git a/dev-util/ninja/ninja-120508.ebuild b/dev-util/ninja/ninja-120508.ebuild
deleted file mode 100644
index 7c61d5d205bc..000000000000
--- a/dev-util/ninja/ninja-120508.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ninja-120508.ebuild,v 1.1 2012/08/08 03:02:16 ottxor Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2"
-
-inherit bash-completion-r1 elisp-common python toolchain-funcs
-
-if [ "${PV}" = "999999" ]; then
- EGIT_REPO_URI="git://github.com/martine/ninja.git http://github.com/martine/ninja.git"
- inherit git-2
- KEYWORDS=""
-else
- inherit vcs-snapshot
- SRC_URI="https://github.com/martine/ninja/tarball/release-${PV} -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="A small build system similar to make."
-HOMEPAGE="http://github.com/martine/ninja"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-IUSE="doc emacs vim-syntax zsh-completion"
-
-DEPEND="doc? ( app-text/asciidoc app-doc/doxygen )"
-RDEPEND="zsh-completion? ( app-shells/zsh )
- emacs? ( virtual/emacs )
- vim-syntax? (
- || (
- app-editors/vim
- app-editors/gvim
- )
- )"
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_compile() {
- tc-export BUILD_CXX
- ./bootstrap.py || die
- if use doc; then
- ./ninja doxygen || die
- fi
-
- if use emacs; then
- elisp-compile misc/ninja-mode.el || die
- fi
-}
-
-src_install() {
- dodoc README HACKING
- use doc && dohtml -r doc/doxygen/html/*
- dobin ninja
-
- newbashcomp misc/bash-completion "${PN}"
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax/
- doins misc/"${PN}".vim
-
- echo 'au BufNewFile,BufRead *.ninja set ft=ninja' > "${T}/${PN}.vim"
- insinto /usr/share/vim/vimfiles/ftdetect
- doins "${T}/${PN}.vim"
- fi
-
- if use zsh-completion; then
- insinto /usr/share/zsh/site-functions
- newins misc/zsh-completion _ninja
- fi
-
- if use emacs; then
- cd misc || die
- elisp-install ${PN} ninja-mode.el* || die
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}