summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-01-29 08:22:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-01-29 08:22:00 +0000
commit60e534e8ed0ed08b9f792b8d97ee29ab84035019 (patch)
tree0e4e18955b087ccf7411afa542b7b674d0e0cb36 /dev-util
parentRevision bump to create stable candidate without ruby19. (diff)
downloadgentoo-2-60e534e8ed0ed08b9f792b8d97ee29ab84035019.tar.gz
gentoo-2-60e534e8ed0ed08b9f792b8d97ee29ab84035019.tar.bz2
gentoo-2-60e534e8ed0ed08b9f792b8d97ee29ab84035019.zip
Added live ebuild (upstream has all fixes in).
(Portage version: 2.2.0_alpha84_p18/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bdelta/ChangeLog9
-rw-r--r--dev-util/bdelta/bdelta-9999.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-util/bdelta/ChangeLog b/dev-util/bdelta/ChangeLog
index b67800562529..07dadef0f8ca 100644
--- a/dev-util/bdelta/ChangeLog
+++ b/dev-util/bdelta/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/bdelta
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bdelta/ChangeLog,v 1.10 2011/12/09 07:24:27 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bdelta/ChangeLog,v 1.11 2012/01/29 08:22:00 slyfox Exp $
+
+*bdelta-9999 (29 Jan 2012)
+
+ 29 Jan 2012; Sergei Trofimovich <slyfox@gentoo.org> +bdelta-9999.ebuild:
+ Added live ebuild (upstream has all fixes in).
09 Dec 2011; Sergei Trofimovich <slyfox@gentoo.org> bdelta-0.2.3.ebuild:
Fixed support for prefix. Keyworded x86-linux.
diff --git a/dev-util/bdelta/bdelta-9999.ebuild b/dev-util/bdelta/bdelta-9999.ebuild
new file mode 100644
index 000000000000..c883bf0a2b0a
--- /dev/null
+++ b/dev-util/bdelta/bdelta-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bdelta/bdelta-9999.ebuild,v 1.1 2012/01/29 08:22:00 slyfox Exp $
+
+EAPI="4"
+
+inherit git-2 multilib toolchain-funcs
+
+DESCRIPTION="Binary Delta - Efficient difference algorithm and format"
+HOMEPAGE="http://bdelta.org"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/jjwhitney/BDelta.git"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=""
+IUSE=""
+
+src_compile() {
+ emake -C src \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ emake -C src install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ dodoc README
+}