summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-05-18 12:02:00 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-05-18 12:02:00 +0000
commit6001b5e25b0b68aca33ee2d4c6c092ee7fea5d88 (patch)
tree3cdc989b25e71395467ebb76c8a5d9de244f5014 /dev-util
parentInitial addition of sci-chemistry/autodock_vina (diff)
downloadgentoo-2-6001b5e25b0b68aca33ee2d4c6c092ee7fea5d88.tar.gz
gentoo-2-6001b5e25b0b68aca33ee2d4c6c092ee7fea5d88.tar.bz2
gentoo-2-6001b5e25b0b68aca33ee2d4c6c092ee7fea5d88.zip
Version bumped.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gtest/ChangeLog8
-rw-r--r--dev-util/gtest/files/gtest-1.5.0-asneeded.patch12
-rw-r--r--dev-util/gtest/gtest-1.5.0.ebuild50
3 files changed, 69 insertions, 1 deletions
diff --git a/dev-util/gtest/ChangeLog b/dev-util/gtest/ChangeLog
index 3a6cb07e81ed..6e52273f0c82 100644
--- a/dev-util/gtest/ChangeLog
+++ b/dev-util/gtest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/gtest
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gtest/ChangeLog,v 1.2 2010/03/02 07:33:16 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtest/ChangeLog,v 1.3 2010/05/18 12:02:00 matsuu Exp $
+
+*gtest-1.5.0 (18 May 2010)
+
+ 18 May 2010; MATSUU Takuto <matsuu@gentoo.org> +gtest-1.5.0.ebuild,
+ +files/gtest-1.5.0-asneeded.patch:
+ Version bumped.
02 Mar 2010; Tiziano Müller <dev-zero@gentoo.org> gtest-1.4.0.ebuild,
metadata.xml:
diff --git a/dev-util/gtest/files/gtest-1.5.0-asneeded.patch b/dev-util/gtest/files/gtest-1.5.0-asneeded.patch
new file mode 100644
index 000000000000..d831bc4f02c0
--- /dev/null
+++ b/dev-util/gtest/files/gtest-1.5.0-asneeded.patch
@@ -0,0 +1,12 @@
+diff -Naur gtest-1.5.0.orig//Makefile.am gtest-1.5.0//Makefile.am
+--- gtest-1.5.0.orig//Makefile.am 2010-04-16 07:02:08.000000000 +0900
++++ gtest-1.5.0//Makefile.am 2010-05-18 17:27:48.000000000 +0900
+@@ -247,7 +247,7 @@
+ TESTS += test/gtest_all_test
+ check_PROGRAMS += test/gtest_all_test
+ test_gtest_all_test_SOURCES = test/gtest_all_test.cc
+-test_gtest_all_test_LDADD = lib/libgtest_main.la
++test_gtest_all_test_LDADD = lib/libgtest.la
+
+ # Tests that fused gtest files compile and work.
+ FUSED_GTEST_SRC = \
diff --git a/dev-util/gtest/gtest-1.5.0.ebuild b/dev-util/gtest/gtest-1.5.0.ebuild
new file mode 100644
index 000000000000..4dce49810adb
--- /dev/null
+++ b/dev-util/gtest/gtest-1.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtest/gtest-1.5.0.ebuild,v 1.1 2010/05/18 12:02:00 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+inherit autotools eutils python
+
+DESCRIPTION="Google C++ Testing Framework"
+HOMEPAGE="http://code.google.com/p/googletest/"
+SRC_URI="http://googletest.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples threads static-libs"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ sed -i -e "s|/tmp|${T}|g" test/gtest-filepath_test.cc || die "sed failed"
+
+ python_convert_shebangs -r 2 .
+
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with threads pthreads) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc CHANGES CONTRIBUTORS README || die
+
+ if ! use static-libs ; then
+ rm "${D}"/usr/lib*/*.la || die
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins samples/*.{cc,h} || die
+ fi
+}