summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-04-06 22:45:44 +0000
committerMichael Weber <xmw@gentoo.org>2011-04-06 22:45:44 +0000
commit39e479817517e43bd53f92a832e00bb560047bd1 (patch)
tree15e47a4c136a7fc9678a2cda64e4b4142754f38d /dev-util
parentForce more recent versions of random packages #352571 by Frossie. (diff)
downloadgentoo-2-39e479817517e43bd53f92a832e00bb560047bd1.tar.gz
gentoo-2-39e479817517e43bd53f92a832e00bb560047bd1.tar.bz2
gentoo-2-39e479817517e43bd53f92a832e00bb560047bd1.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/skipfish/ChangeLog9
-rw-r--r--dev-util/skipfish/skipfish-1.85_beta.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-util/skipfish/ChangeLog b/dev-util/skipfish/ChangeLog
index c5dd1890e5ca..0e4b5aae7196 100644
--- a/dev-util/skipfish/ChangeLog
+++ b/dev-util/skipfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/skipfish
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/ChangeLog,v 1.6 2010/07/29 11:16:07 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/ChangeLog,v 1.7 2011/04/06 22:45:44 xmw Exp $
+
+*skipfish-1.85_beta (06 Apr 2011)
+
+ 06 Apr 2011; Michael Weber <xmw@gentoo.org> +skipfish-1.85_beta.ebuild:
+ Version bump (thanks to anton.bugs@gmail.com on bug 360045)
*skipfish-1.52_beta (29 Jul 2010)
diff --git a/dev-util/skipfish/skipfish-1.85_beta.ebuild b/dev-util/skipfish/skipfish-1.85_beta.ebuild
new file mode 100644
index 000000000000..0c0cda62a3de
--- /dev/null
+++ b/dev-util/skipfish/skipfish-1.85_beta.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/skipfish-1.85_beta.ebuild,v 1.1 2011/04/06 22:45:44 xmw Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+MY_P=${P/_beta/b}
+
+DESCRIPTION="A fully automated, active web application security reconnaissance tool"
+HOMEPAGE="http://code.google.com/p/skipfish/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="Apache-2.0 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/openssl
+ net-dns/libidn
+ sys-libs/zlib"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS_GEN/s:-g -ggdb::' \
+ -e '/CFLAGS_OPT/s:-O3::' \
+ Makefile || die
+
+ sed -i \
+ -e "/ASSETS_DIR/s:assets:/usr/share/doc/${PF}/html:" \
+ config.h || die
+}
+
+src_compile() {
+ tc-export CC
+
+ local _debug
+ use debug && _debug=debug
+
+ emake ${_debug} || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ doman ${PN}.1 || die
+
+ insinto /usr/share/${PN}/dictionaries
+ doins dictionaries/*.wl || die
+
+ dohtml assets/* || die
+
+ dodoc ChangeLog dictionaries/README-FIRST README
+}