summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-22 12:41:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-22 12:41:29 +0000
commit269273d0843ce6d255c25008bec2d789e4efd790 (patch)
tree28537ccb4ef1d6b484c41ac0c782734fab83468a /dev-util
parentold (diff)
downloadgentoo-2-269273d0843ce6d255c25008bec2d789e4efd790.tar.gz
gentoo-2-269273d0843ce6d255c25008bec2d789e4efd790.tar.bz2
gentoo-2-269273d0843ce6d255c25008bec2d789e4efd790.zip
old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgconfig/ChangeLog5
-rw-r--r--dev-util/pkgconfig/pkgconfig-0.28.ebuild91
2 files changed, 4 insertions, 92 deletions
diff --git a/dev-util/pkgconfig/ChangeLog b/dev-util/pkgconfig/ChangeLog
index 35fb4da0b86d..7720a6d3de25 100644
--- a/dev-util/pkgconfig/ChangeLog
+++ b/dev-util/pkgconfig/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/pkgconfig
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.155 2014/07/22 12:39:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.156 2014/07/22 12:41:29 ssuominen Exp $
+
+ 22 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> -pkgconfig-0.28.ebuild:
+ old
22 Jul 2014; Mike Frysinger <vapier@gentoo.org> pkgconfig-0.28-r1.ebuild:
Mark stable for m68k/s390/sh/sparc.
diff --git a/dev-util/pkgconfig/pkgconfig-0.28.ebuild b/dev-util/pkgconfig/pkgconfig-0.28.ebuild
deleted file mode 100644
index 57a62f4a4b2d..000000000000
--- a/dev-util/pkgconfig/pkgconfig-0.28.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.28.ebuild,v 1.15 2014/02/01 16:18:05 grobian Exp $
-
-EAPI=5
-
-inherit flag-o-matic libtool multilib
-
-MY_P=pkg-config-${PV}
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="git://anongit.freedesktop.org/pkg-config"
- inherit autotools git-2
-else
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- SRC_URI="http://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="Package config system that manages compile/link flags"
-HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="elibc_FreeBSD elibc_glibc hardened internal-glib"
-
-RDEPEND="!internal-glib? ( >=dev-libs/glib-2.30 )
- !dev-util/pkgconf[pkg-config]
- !dev-util/pkg-config-lite
- !dev-util/pkgconfig-openbsd[pkg-config]"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS=( AUTHORS NEWS README )
-
-src_prepare() {
- sed -i -e "s|^prefix=/usr\$|prefix=${EPREFIX}/usr|" check/simple.pc || die #434320
-
- if [[ ${PV} == *9999* ]]; then
- eautoreconf
- else
- elibtoolize # Required for FreeMiNT wrt #333429
- fi
-}
-
-src_configure() {
- local myconf
-
- if use internal-glib; then
- myconf+=' --with-internal-glib'
- # non-glibc platforms use GNU libiconv, but configure needs to
- # know about that not to get confused when it finds something
- # outside the prefix too
- if use prefix && use !elibc_glibc ; then
- myconf+=" --with-libiconv=gnu"
- # add the libdir for libtool, otherwise it'll make love with system
- # installed libiconv
- append-ldflags "-L${EPREFIX}/usr/$(get_libdir)"
- fi
- else
- if ! has_version dev-util/pkgconfig; then
- export GLIB_CFLAGS="-I${EPREFIX}/usr/include/glib-2.0 -I${EPREFIX}/usr/$(get_libdir)/glib-2.0/include"
- export GLIB_LIBS="-lglib-2.0"
- fi
- fi
-
- use ppc64 && use hardened && replace-flags -O[2-3] -O1
-
- # Force using all the requirements when linking, so that needed -pthread
- # lines are inherited between libraries
- use elibc_FreeBSD && myconf+=' --enable-indirect-deps'
-
- [[ ${PV} == *9999* ]] && myconf+=' --enable-maintainer-mode'
-
- econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF}/html \
- --with-system-include-path="${EPREFIX}"/usr/include \
- --with-system-library-path="${EPREFIX}"/usr/$(get_libdir) \
- ${myconf}
-}
-
-src_install() {
- default
-
- if use prefix; then
- # Add an explicit reference to $EPREFIX to PKG_CONFIG_PATH to
- # simplify cross-prefix builds
- echo "PKG_CONFIG_PATH=${EPREFIX}/usr/$(get_libdir)/pkgconfig:${EPREFIX}/usr/share/pkgconfig" >> "${T}"/99${PN}
- doenvd "${T}"/99${PN}
- fi
-}