summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-05-24 19:13:48 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-05-24 19:13:48 +0000
commit29f353674defa9f0672309e1cc7761f16ee654a1 (patch)
treeb682d654002d25e2873f4cca314b4af752500be0 /dev-util/wxglade/wxglade-0.3.3.ebuild
parentMark stable for sparc. (Manifest recommit) (diff)
downloadgentoo-2-29f353674defa9f0672309e1cc7761f16ee654a1.tar.gz
gentoo-2-29f353674defa9f0672309e1cc7761f16ee654a1.tar.bz2
gentoo-2-29f353674defa9f0672309e1cc7761f16ee654a1.zip
Version bump
Diffstat (limited to 'dev-util/wxglade/wxglade-0.3.3.ebuild')
-rw-r--r--dev-util/wxglade/wxglade-0.3.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/wxglade/wxglade-0.3.3.ebuild b/dev-util/wxglade/wxglade-0.3.3.ebuild
new file mode 100644
index 000000000000..b3a514e40504
--- /dev/null
+++ b/dev-util/wxglade/wxglade-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.3.3.ebuild,v 1.1 2004/05/24 19:13:48 pythonhead Exp $
+
+S="${WORKDIR}/wxGlade-${PV}"
+DESCRIPTION="Glade-like GUI designer which can generate Python, Perl, C++ or XRC code"
+HOMEPAGE="http://wxglade.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wxglade/wxGlade-${PV}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/wxPython-2.4.2.4"
+
+src_install() {
+ PY_VER=`python -c 'import sys;print sys.version[0:3]'`
+ dodir /usr/lib/python${PY_VER}/site-packages/${PN}
+ dodoc *txt
+ cp credits.txt ${D}/usr/lib/python${PY_VER}/site-packages/${PN}/
+ dohtml -r docs/*
+ rm -rf docs *txt
+ cp -R * ${D}/usr/lib/python${PY_VER}/site-packages/${PN}/
+ dosym /usr/share/doc/${PF}/html /usr/lib/python${PY_VER}/site-packages/${PN}/docs
+ echo "#!/bin/bash" > wxglade
+ echo "/usr/lib/python${PY_VER}/site-packages/${PN}/wxglade.py" >> wxglade
+ exeinto /usr/bin
+ doexe wxglade
+}
+