summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-04-16 19:55:23 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-04-16 19:55:23 +0000
commitadf3a14e6c0f6fe09641414a567e58f343e7c141 (patch)
tree59edad22bb4ecda922f186043896a1337b18466c /dev-util/wxglade/wxglade-0.3.2.ebuild
parentadded s390 to keywords (Manifest recommit) (diff)
downloadgentoo-2-adf3a14e6c0f6fe09641414a567e58f343e7c141.tar.gz
gentoo-2-adf3a14e6c0f6fe09641414a567e58f343e7c141.tar.bz2
gentoo-2-adf3a14e6c0f6fe09641414a567e58f343e7c141.zip
Version bump (bug #45881)
Diffstat (limited to 'dev-util/wxglade/wxglade-0.3.2.ebuild')
-rw-r--r--dev-util/wxglade/wxglade-0.3.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/wxglade/wxglade-0.3.2.ebuild b/dev-util/wxglade/wxglade-0.3.2.ebuild
new file mode 100644
index 000000000000..81e49044b328
--- /dev/null
+++ b/dev-util/wxglade/wxglade-0.3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.3.2.ebuild,v 1.1 2004/04/16 19:55:23 pythonhead Exp $
+
+S="${WORKDIR}/wxGlade-${PV}"
+DESCRIPTION="Glade-like GUI designer which can generate Python, Perl, C++ or XRC code"
+HOMEPAGE="http://wxglade.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wxglade/wxGlade-${PV}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/wxPython-2.4.2.4"
+
+src_install() {
+ PY_VER=`python -c 'import sys;print sys.version[0:3]'`
+ dodir /usr/lib/python${PY_VER}/site-packages/${PN}
+ dodoc *txt
+ cp credits.txt ${D}/usr/lib/python${PY_VER}/site-packages/${PN}/
+ dohtml -r docs/*
+ rm -rf docs *txt
+ mv examples ${D}/usr/share/doc/${PF}
+ cp -R * ${D}/usr/lib/python${PY_VER}/site-packages/${PN}/
+ dosym /usr/share/doc/${PF}/html /usr/lib/python${PY_VER}/site-packages/${PN}/docs
+ echo "#!/bin/bash" > wxglade
+ echo "/usr/lib/python${PY_VER}/site-packages/${PN}/wxglade.py" >> wxglade
+ exeinto /usr/bin
+ doexe wxglade
+}
+