summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-05-01 13:03:29 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-05-01 13:03:29 +0000
commit1c0a7dce4dc3941cd102436295a4151efb4ae5a1 (patch)
tree68e71ad0c53ccc4072e31b3ab73bba0743e13ccc /dev-util/valgrind
parentvdr-plugin-2.eclass (diff)
downloadgentoo-2-1c0a7dce4dc3941cd102436295a4151efb4ae5a1.tar.gz
gentoo-2-1c0a7dce4dc3941cd102436295a4151efb4ae5a1.tar.bz2
gentoo-2-1c0a7dce4dc3941cd102436295a4151efb4ae5a1.zip
Add OSX support, bug #359993
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/valgrind')
-rw-r--r--dev-util/valgrind/ChangeLog8
-rw-r--r--dev-util/valgrind/files/valgrind-3.7.0-non-exec-darwin.patch31
-rw-r--r--dev-util/valgrind/valgrind-3.7.0-r4.ebuild109
3 files changed, 147 insertions, 1 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index d21297a3e4a8..53c02460bda1 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/valgrind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.142 2012/04/28 16:50:42 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.143 2012/05/01 13:03:29 blueness Exp $
+
+*valgrind-3.7.0-r4 (01 May 2012)
+
+ 01 May 2012; Anthony G. Basile <blueness@gentoo.org>
+ +valgrind-3.7.0-r4.ebuild, +files/valgrind-3.7.0-non-exec-darwin.patch:
+ Add OSX support, bug #359993
28 Apr 2012; Anthony G. Basile <blueness@gentoo.org> valgrind-3.4.0.ebuild,
valgrind-3.4.1.ebuild, valgrind-3.4.1-r1.ebuild, valgrind-3.5.0.ebuild,
diff --git a/dev-util/valgrind/files/valgrind-3.7.0-non-exec-darwin.patch b/dev-util/valgrind/files/valgrind-3.7.0-non-exec-darwin.patch
new file mode 100644
index 000000000000..19e7cac0704c
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.7.0-non-exec-darwin.patch
@@ -0,0 +1,31 @@
+--- files/valgrind-3.7.0-non-exec-stack.patch.orig 2011-11-11 02:40:06.000000000 +0100
++++ files/valgrind-3.7.0-non-exec-stack.patch 2012-03-23 20:11:36.000000000 +0100
+@@ -40,7 +40,7 @@
+ m_syswrap/syswrap-main.c \
+ m_syswrap/syswrap-generic.c \
+ m_syswrap/syswrap-linux.c \
+-@@ -361,6 +343,24 @@
++@@ -361,6 +343,29 @@
+ m_ume/main.c \
+ m_ume/script.c
+
+@@ -56,11 +56,16 @@
+ +
+ +if VGCONF_OS_IS_DARWIN
+ +COREGRIND_SOURCES_COMMON += \
+-+ m_start-@VGCONF_ARCH_PRI@-darwin.S \
+-+ m_start-@VGCONF_ARCH_SEC@-darwin.S \
+-+ m_mach/mach_traps-@VGCONF_ARCH_PRI@-darwin.S \
+++ m_dispatch/dispatch-@VGCONF_ARCH_PRI@-darwin.S \
+++ m_syswrap/syscall-@VGCONF_ARCH_PRI@-darwin.S \
+++ m_mach/mach_traps-@VGCONF_ARCH_PRI@-darwin.S
+++if VGCONF_HAVE_PLATFORM_SEC
+++COREGRIND_SOURCES_COMMON += \
+++ m_dispatch/dispatch-@VGCONF_ARCH_SEC@-darwin.S \
+++ m_syswrap/syscall-@VGCONF_ARCH_SEC@-darwin.S \
+ + m_mach/mach_traps-@VGCONF_ARCH_SEC@-darwin.S
+ +endif
+++endif
+ +
+ libcoregrind_@VGCONF_ARCH_PRI@_@VGCONF_OS@_a_SOURCES = \
+ $(COREGRIND_SOURCES_COMMON)
diff --git a/dev-util/valgrind/valgrind-3.7.0-r4.ebuild b/dev-util/valgrind/valgrind-3.7.0-r4.ebuild
new file mode 100644
index 000000000000..2a5d0792ac75
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.7.0-r4.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.7.0-r4.ebuild,v 1.1 2012/05/01 13:03:29 blueness Exp $
+
+EAPI="4"
+inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x64-macos"
+IUSE="mpi"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
+
+ # Don't force multiarch stuff on OSX, bug #306467
+ sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
+
+ # Respect CFLAGS, LDFLAGS
+ epatch "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
+
+ # Changing Makefile.all.am to disable SSP
+ epatch "${FILESDIR}"/${PN}-3.7.0-fno-stack-protector.patch
+
+ # Yet more local labels, this time for ppc32 & ppc64
+ epatch "${FILESDIR}"/${PN}-3.6.0-local-labels.patch
+
+ # Don't build in empty assembly files for other platforms or we'll get a QA
+ # warning about executable stacks.
+ epatch "${FILESDIR}"/${PN}-3.7.0-non-exec-stack.patch
+
+ # Fix the regex to get gcc's version
+ epatch "${FILESDIR}"/${PN}-3.7.0-fix-gcc-regex.patch
+
+ # Fix stricter use of dir variables, bug #397429
+ epatch "${FILESDIR}"/${PN}-3.7.0-automake-1.11.2.patch
+
+ # Fix for glibc 2.15, bug #398921
+ epatch "${FILESDIR}"/${PN}-3.7.0-glibc-2.15.patch
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fpie valgrind seemingly hangs when built with pie on
+ # amd64 (bug #102157)
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -m64 -mx32 for multilib-portage, bug #398825
+ # -ggdb3 segmentation fault on startup
+ filter-flags -fomit-frame-pointer
+ filter-flags -fpie
+ filter-flags -fstack-protector
+ filter-flags -m64 -mx32
+ replace-flags -ggdb3 -ggdb2
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ fi
+
+ # Force bitness on darwin, bug #306467
+ use x86-macos && myconf="${myconf} --enable-only32bit"
+ use x64-macos && myconf="${myconf} --enable-only64bit"
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf="${myconf} --without-mpicc"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ dodoc AUTHORS FAQ.txt NEWS README*
+
+ pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # fix install_names on shared libraries, can't turn them into bundles,
+ # as dyld won't load them any more then, bug #306467
+ local l
+ for l in "${ED}"/usr/lib/valgrind/*.so ; do
+ install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ ewarn "Valgrind will not work if glibc does not have debug symbols."
+ ewarn "To fix this you can add splitdebug to FEATURES in make.conf"
+ ewarn "and remerge glibc. See:"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=214065"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=274771"
+ ewarn "https://bugs.gentoo.org/show_bug.cgi?id=388703"
+}