summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoannis Aslanidis <deathwing00@gentoo.org>2009-02-12 14:00:05 +0000
committerIoannis Aslanidis <deathwing00@gentoo.org>2009-02-12 14:00:05 +0000
commit53511446d610883f2286eb0cfc7cd81372dc440c (patch)
tree4eb6045a74df90d65ee70d0b0e6b39878d7262c7 /dev-util/radare
parentrenamed CVE patch to match the publication number - bug #257075 (diff)
downloadgentoo-2-53511446d610883f2286eb0cfc7cd81372dc440c.tar.gz
gentoo-2-53511446d610883f2286eb0cfc7cd81372dc440c.tar.bz2
gentoo-2-53511446d610883f2286eb0cfc7cd81372dc440c.zip
Version bump. Several ebuild improvements and fixes.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/radare')
-rw-r--r--dev-util/radare/ChangeLog13
-rw-r--r--dev-util/radare/metadata.xml5
-rw-r--r--dev-util/radare/radare-1.2.1.ebuild27
3 files changed, 43 insertions, 2 deletions
diff --git a/dev-util/radare/ChangeLog b/dev-util/radare/ChangeLog
index 59291a6c16bf..33ce82d50673 100644
--- a/dev-util/radare/ChangeLog
+++ b/dev-util/radare/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/radare
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/radare/ChangeLog,v 1.1 2008/07/31 17:54:59 deathwing00 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/radare/ChangeLog,v 1.2 2009/02/12 14:00:05 deathwing00 Exp $
+
+*radare-1.2.1 (12 Feb 2009)
+
+ 12 Feb 2009; Ioannis Aslanidis <iaslanidis@gentoo.org> metadata.xml,
+ +radare-1.2.1.ebuild:
+ Version bump. Parallel build is bogus and creates race conditions. Created a
+ local use flag to optionally build the gui. Currently there are a few missing
+ dependencies that need to be fixed sooner or later for the gui to work
+ properly.
*radare-0.9.9 (31 Jul 2008)
diff --git a/dev-util/radare/metadata.xml b/dev-util/radare/metadata.xml
index 40c6bc24b621..054686dc09e3 100644
--- a/dev-util/radare/metadata.xml
+++ b/dev-util/radare/metadata.xml
@@ -2,6 +2,11 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>kde</herd>
+<use>
+ <flag name='gui'>
+ Enable the graphical user interface of radare (broken)
+ </flag>
+</use>
<maintainer>
<email>deathwing00@gentoo.org</email>
<name>Ioannis Aslanidis</name>
diff --git a/dev-util/radare/radare-1.2.1.ebuild b/dev-util/radare/radare-1.2.1.ebuild
new file mode 100644
index 000000000000..5323a4ad2fe4
--- /dev/null
+++ b/dev-util/radare/radare-1.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/radare/radare-1.2.1.ebuild,v 1.1 2009/02/12 14:00:05 deathwing00 Exp $
+
+DESCRIPTION="Advanced command line hexadecimail editor and more"
+HOMEPAGE="http://radare.nopcode.org"
+SRC_URI="http://radare.nopcode.org/get/radare-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="gui"
+
+DEPEND="sys-libs/readline
+ dev-lang/python
+ "
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf $(use_with gui) || die "configure failed"
+ emake -j1 || die "compile failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}
+