summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-07-09 01:02:48 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-07-09 01:02:48 +0000
commitf1bb5d94b2880f4ec961048622082c5602998a41 (patch)
treee6d6cd8cd997953ccdbc37a261a45cdeab55e144 /dev-util/poedit/poedit-1.2.2.ebuild
parentnew wxGTK and various wxwindows apps (diff)
downloadgentoo-2-f1bb5d94b2880f4ec961048622082c5602998a41.tar.gz
gentoo-2-f1bb5d94b2880f4ec961048622082c5602998a41.tar.bz2
gentoo-2-f1bb5d94b2880f4ec961048622082c5602998a41.zip
new wxGTK and various wxwindows apps
Diffstat (limited to 'dev-util/poedit/poedit-1.2.2.ebuild')
-rw-r--r--dev-util/poedit/poedit-1.2.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/poedit/poedit-1.2.2.ebuild b/dev-util/poedit/poedit-1.2.2.ebuild
new file mode 100644
index 000000000000..269096fca65b
--- /dev/null
+++ b/dev-util/poedit/poedit-1.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/poedit/poedit-1.2.2.ebuild,v 1.1 2003/07/09 01:01:55 liquidx Exp $
+
+inherit eutils kde
+
+IUSE="kde"
+DESCRIPTION="Cross-platform gettext catalogs (.po files) editor."
+SRC_URI="mirror://sourceforge/poedit/${P}.tar.bz2"
+HOMEPAGE="http://poedit.sourceforge.net/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND=">=x11-libs/wxGTK-2.3.4
+ >=sys-libs/db-3"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install () {
+
+ einstall \
+ datadir=${D}/usr/share \
+ GNOME_DATA_DIR=${D}/usr/share \
+ KDE_DATA_DIR=${D}/${KDEDIR-/usr}/share || die
+
+ dodoc AUTHORS LICENSE NEWS README TODO
+}