summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-06-21 14:35:52 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-06-21 14:35:52 +0000
commitf8171a888f0194305aa332ab330da4f5b7beeaf9 (patch)
tree1d58c17c12142890a03f06fb4af4e040c791384a /dev-util/plan9port
parentfix for bug 474018 Possibility of arbitrary code execution when processing un... (diff)
downloadgentoo-2-f8171a888f0194305aa332ab330da4f5b7beeaf9.tar.gz
gentoo-2-f8171a888f0194305aa332ab330da4f5b7beeaf9.tar.bz2
gentoo-2-f8171a888f0194305aa332ab330da4f5b7beeaf9.zip
Optionally depend on X, fix build system, bug #463616
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-util/plan9port')
-rw-r--r--dev-util/plan9port/ChangeLog10
-rw-r--r--dev-util/plan9port/files/plan9port-builderr.patch29
-rw-r--r--dev-util/plan9port/plan9port-20130131.ebuild76
-rw-r--r--dev-util/plan9port/plan9port-20130209-r1.ebuild76
-rw-r--r--dev-util/plan9port/plan9port-20130308.ebuild76
-rw-r--r--dev-util/plan9port/plan9port-20130320-r1.ebuild (renamed from dev-util/plan9port/plan9port-20130119.ebuild)14
6 files changed, 48 insertions, 233 deletions
diff --git a/dev-util/plan9port/ChangeLog b/dev-util/plan9port/ChangeLog
index 735c144d108f..c9c49da69d47 100644
--- a/dev-util/plan9port/ChangeLog
+++ b/dev-util/plan9port/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/plan9port
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/ChangeLog,v 1.15 2013/03/22 12:06:39 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/ChangeLog,v 1.16 2013/06/21 14:35:52 blueness Exp $
+
+*plan9port-20130320-r1 (21 Jun 2013)
+
+ 21 Jun 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/plan9port-builderr.patch, +plan9port-20130320-r1.ebuild,
+ -plan9port-20130119.ebuild, -plan9port-20130131.ebuild,
+ -plan9port-20130209-r1.ebuild, -plan9port-20130308.ebuild:
+ Optionally depend on X, fix build system, bug #463616
*plan9port-20130320 (22 Mar 2013)
diff --git a/dev-util/plan9port/files/plan9port-builderr.patch b/dev-util/plan9port/files/plan9port-builderr.patch
new file mode 100644
index 000000000000..266f10c4b9d5
--- /dev/null
+++ b/dev-util/plan9port/files/plan9port-builderr.patch
@@ -0,0 +1,29 @@
+Prevent mk from ignoring errors
+
+By default, the plan9port INSTALL script doesn't report build error,
+which can result in a mostly broken build begin installed.
+--- a/INSTALL
++++ b/INSTALL
+@@ -41,7 +41,6 @@ echo " "
+ echo "* Resetting $PLAN9/config"
+ rm -f config
+
+-(
+ echo "* Compiler version:"
+ 9c -v 2>&1 | grep -v 'Configured with:' | grep -i version | sed 's/^/ /'
+
+@@ -134,7 +133,7 @@ if $dobuild; then
+ echo "* Warning: not all binaries built successfully."
+ fi
+ echo "* Installing everything in $PLAN9/bin..."
+- mk -k install || exit 1
++ mk install || exit 1
+ if [ ! -x $PLAN9/bin/cleanname -o ! -x $PLAN9/bin/acme -o ! -x $PLAN9/bin/sam ]; then
+ echo " "
+ echo "* Warning: not all binaries built successfully."
+@@ -182,5 +181,4 @@ if $doinstall; then
+ echo " PLAN9=$PLAN9 export PLAN9"
+ echo ' PATH=$PATH:$PLAN9/bin export PATH'
+ fi
+-) 2>&1 | tee install.log | $awk -f $PLAN9/dist/isum.awk -v 'copy='install.sum
+
diff --git a/dev-util/plan9port/plan9port-20130131.ebuild b/dev-util/plan9port/plan9port-20130131.ebuild
deleted file mode 100644
index 55f81933a0d6..000000000000
--- a/dev-util/plan9port/plan9port-20130131.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/plan9port-20130131.ebuild,v 1.1 2013/02/02 01:32:40 blueness Exp $
-
-EAPI="4"
-
-inherit eutils
-
-DESCRIPTION="Port of many Plan 9 programs and libraries"
-HOMEPAGE="http://swtch.com/plan9port/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tgz"
-
-LICENSE="9base BSD-4 MIT LGPL-2.1 BigelowHolmes"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="x11-apps/xauth"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-PLAN9=/usr/lib/plan9
-
-src_prepare()
-{
- epatch "${FILESDIR}/${PN}-"{9660srv-errno,noexecstack}".patch"
-
- # Fix paths, done in place of ./INSTALL -c
- einfo "Fixing hard-coded /usr/local/plan9 paths"
- grep --null -l -r '/usr/local/plan9' |
- xargs --null sed -i "s!/usr/local/plan9!${PLAN9}!g"
-}
-
-src_compile() {
- # Convert -j5 to NPROC=5 for mk
- export NPROC="$(echo "$MAKEOPTS" | sed -r -n 's/.*(^| )-j([0-9]*).*/\2/p')"
-
- # The INSTALL script builds mk then [re]builds everything using that
- einfo "Compiling Plan 9 from User Space can take a very long time"
- einfo "depending on the speed of your computer. Please be patient!"
- ./INSTALL -b
-}
-
-src_install() {
- dodir "${PLAN9}"
-
- # P9P's man does not handle compression
- docompress -x $PLAN9/man
-
- # do* plays with the executable bit, and we should not modify them
- cp -a * "${D}/${PLAN9}"
-
- # build the environment variables and install them in env.d
- cat > "${T}/30plan9" <<-EOF
- PLAN9="${PLAN9}"
- PATH="${PLAN9}/bin"
- ROOTPATH="${PLAN9}/bin"
- MANPATH="${PLAN9}/man"
- EOF
- doenvd "${T}/30plan9"
-}
-
-pkg_postinst() {
- elog "Plan 9 from User Space has been successfully installed into"
- elog "${PLAN9}. Your PLAN9 and PATH environment variables have"
- elog "also been appropriately set, please use env-update and"
- elog "source /etc/profile to bring that into immediate effect."
- elog
- elog "Please note that ${PLAN9}/bin has been appended to the"
- elog "*end* or your PATH to prevent conflicts. To use the Plan9"
- elog "versions of common UNIX tools, use the absolute path:"
- elog "${PLAN9}/bin or the 9 command (eg: 9 troff)"
- elog
- elog "Please report any bugs to bugs.gentoo.org, NOT Plan9Port."
-}
diff --git a/dev-util/plan9port/plan9port-20130209-r1.ebuild b/dev-util/plan9port/plan9port-20130209-r1.ebuild
deleted file mode 100644
index 5d456f73b453..000000000000
--- a/dev-util/plan9port/plan9port-20130209-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/plan9port-20130209-r1.ebuild,v 1.1 2013/02/12 01:27:31 blueness Exp $
-
-EAPI="4"
-
-inherit eutils
-
-DESCRIPTION="Port of many Plan 9 programs and libraries"
-HOMEPAGE="http://swtch.com/plan9port/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tgz"
-
-LICENSE="9base BSD-4 MIT LGPL-2.1 BigelowHolmes"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="x11-apps/xauth"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-PLAN9=/usr/lib/plan9
-
-src_prepare()
-{
- epatch "${FILESDIR}/${PN}-"{9660srv-errno,noexecstack,cflags}".patch"
-
- # Fix paths, done in place of ./INSTALL -c
- einfo "Fixing hard-coded /usr/local/plan9 paths"
- grep --null -l -r '/usr/local/plan9' |
- xargs --null sed -i "s!/usr/local/plan9!${PLAN9}!g"
-}
-
-src_compile() {
- # Convert -j5 to NPROC=5 for mk
- export NPROC="$(echo "$MAKEOPTS" | sed -r -n 's/.*(^| )-j([0-9]*).*/\2/p')"
-
- # The INSTALL script builds mk then [re]builds everything using that
- einfo "Compiling Plan 9 from User Space can take a very long time"
- einfo "depending on the speed of your computer. Please be patient!"
- ./INSTALL -b
-}
-
-src_install() {
- dodir "${PLAN9}"
-
- # P9P's man does not handle compression
- docompress -x $PLAN9/man
-
- # do* plays with the executable bit, and we should not modify them
- cp -a * "${D}/${PLAN9}"
-
- # build the environment variables and install them in env.d
- cat > "${T}/30plan9" <<-EOF
- PLAN9="${PLAN9}"
- PATH="${PLAN9}/bin"
- ROOTPATH="${PLAN9}/bin"
- MANPATH="${PLAN9}/man"
- EOF
- doenvd "${T}/30plan9"
-}
-
-pkg_postinst() {
- elog "Plan 9 from User Space has been successfully installed into"
- elog "${PLAN9}. Your PLAN9 and PATH environment variables have"
- elog "also been appropriately set, please use env-update and"
- elog "source /etc/profile to bring that into immediate effect."
- elog
- elog "Please note that ${PLAN9}/bin has been appended to the"
- elog "*end* or your PATH to prevent conflicts. To use the Plan9"
- elog "versions of common UNIX tools, use the absolute path:"
- elog "${PLAN9}/bin or the 9 command (eg: 9 troff)"
- elog
- elog "Please report any bugs to bugs.gentoo.org, NOT Plan9Port."
-}
diff --git a/dev-util/plan9port/plan9port-20130308.ebuild b/dev-util/plan9port/plan9port-20130308.ebuild
deleted file mode 100644
index 32062af2bae7..000000000000
--- a/dev-util/plan9port/plan9port-20130308.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/plan9port-20130308.ebuild,v 1.1 2013/03/09 15:14:40 blueness Exp $
-
-EAPI="4"
-
-inherit eutils
-
-DESCRIPTION="Port of many Plan 9 programs and libraries"
-HOMEPAGE="http://swtch.com/plan9port/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tgz"
-
-LICENSE="9base BSD-4 MIT LGPL-2.1 BigelowHolmes"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="x11-apps/xauth"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-PLAN9=/usr/lib/plan9
-
-src_prepare()
-{
- epatch "${FILESDIR}/${PN}-"{9660srv-errno,noexecstack,cflags}".patch"
-
- # Fix paths, done in place of ./INSTALL -c
- einfo "Fixing hard-coded /usr/local/plan9 paths"
- grep --null -l -r '/usr/local/plan9' |
- xargs --null sed -i "s!/usr/local/plan9!${PLAN9}!g"
-}
-
-src_compile() {
- # Convert -j5 to NPROC=5 for mk
- export NPROC="$(echo "$MAKEOPTS" | sed -r -n 's/.*(^| )-j([0-9]*).*/\2/p')"
-
- # The INSTALL script builds mk then [re]builds everything using that
- einfo "Compiling Plan 9 from User Space can take a very long time"
- einfo "depending on the speed of your computer. Please be patient!"
- ./INSTALL -b
-}
-
-src_install() {
- dodir "${PLAN9}"
-
- # P9P's man does not handle compression
- docompress -x $PLAN9/man
-
- # do* plays with the executable bit, and we should not modify them
- cp -a * "${D}/${PLAN9}"
-
- # build the environment variables and install them in env.d
- cat > "${T}/30plan9" <<-EOF
- PLAN9="${PLAN9}"
- PATH="${PLAN9}/bin"
- ROOTPATH="${PLAN9}/bin"
- MANPATH="${PLAN9}/man"
- EOF
- doenvd "${T}/30plan9"
-}
-
-pkg_postinst() {
- elog "Plan 9 from User Space has been successfully installed into"
- elog "${PLAN9}. Your PLAN9 and PATH environment variables have"
- elog "also been appropriately set, please use env-update and"
- elog "source /etc/profile to bring that into immediate effect."
- elog
- elog "Please note that ${PLAN9}/bin has been appended to the"
- elog "*end* or your PATH to prevent conflicts. To use the Plan9"
- elog "versions of common UNIX tools, use the absolute path:"
- elog "${PLAN9}/bin or the 9 command (eg: 9 troff)"
- elog
- elog "Please report any bugs to bugs.gentoo.org, NOT Plan9Port."
-}
diff --git a/dev-util/plan9port/plan9port-20130119.ebuild b/dev-util/plan9port/plan9port-20130320-r1.ebuild
index bfa197ba518a..9a1cbe1a0f01 100644
--- a/dev-util/plan9port/plan9port-20130119.ebuild
+++ b/dev-util/plan9port/plan9port-20130320-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/plan9port-20130119.ebuild,v 1.1 2013/01/20 10:58:07 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/plan9port-20130320-r1.ebuild,v 1.1 2013/06/21 14:35:52 blueness Exp $
EAPI="4"
@@ -13,9 +13,9 @@ SRC_URI="http://${PN}.googlecode.com/files/${P}.tgz"
LICENSE="9base BSD-4 MIT LGPL-2.1 BigelowHolmes"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="X"
-DEPEND="x11-apps/xauth"
+DEPEND="X? ( x11-apps/xauth )"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}"
@@ -24,7 +24,7 @@ PLAN9=/usr/lib/plan9
src_prepare()
{
- epatch "${FILESDIR}/${PN}-"{9660srv-errno,noexecstack}".patch"
+ epatch "${FILESDIR}/${PN}-"{9660srv-errno,noexecstack,cflags,builderr}".patch"
# Fix paths, done in place of ./INSTALL -c
einfo "Fixing hard-coded /usr/local/plan9 paths"
@@ -32,6 +32,12 @@ src_prepare()
xargs --null sed -i "s!/usr/local/plan9!${PLAN9}!g"
}
+src_configure() {
+ if ! use X; then
+ echo "WSYSTYPE=nowsys" >> LOCAL.config
+ fi
+}
+
src_compile() {
# Convert -j5 to NPROC=5 for mk
export NPROC="$(echo "$MAKEOPTS" | sed -r -n 's/.*(^| )-j([0-9]*).*/\2/p')"