summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-12-30 04:35:47 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-12-30 04:35:47 +0000
commitc89dab09fdb36691b76a5330b7dce31beb91e901 (patch)
treeceb86087cf9b5a455da09aa0963b4554b2cab36d /dev-util/monotone
parentfix install path (Manifest recommit) (diff)
downloadgentoo-2-c89dab09fdb36691b76a5330b7dce31beb91e901.tar.gz
gentoo-2-c89dab09fdb36691b76a5330b7dce31beb91e901.tar.bz2
gentoo-2-c89dab09fdb36691b76a5330b7dce31beb91e901.zip
initial import as per bug #39383
Diffstat (limited to 'dev-util/monotone')
-rw-r--r--dev-util/monotone/ChangeLog11
-rw-r--r--dev-util/monotone/Manifest3
-rw-r--r--dev-util/monotone/files/digest-monotone-0.151
-rw-r--r--dev-util/monotone/metadata.xml12
-rw-r--r--dev-util/monotone/monotone-0.15.ebuild56
5 files changed, 83 insertions, 0 deletions
diff --git a/dev-util/monotone/ChangeLog b/dev-util/monotone/ChangeLog
new file mode 100644
index 000000000000..495b64a45c82
--- /dev/null
+++ b/dev-util/monotone/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-util/monotone
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.1 2004/12/30 04:35:47 dragonheart Exp $
+
+*monotone-0.15 (30 Dec 2004)
+
+ 30 Dec 2004; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
+ +monotone-0.15.ebuild:
+ initial import as per bug #39383. Ebuild based of contributions from Peter
+ Simons <simons@cryp.to> and Wojciech Milkowski <wmilkowski@gazeta.pl>.
+
diff --git a/dev-util/monotone/Manifest b/dev-util/monotone/Manifest
new file mode 100644
index 000000000000..63412cb879fe
--- /dev/null
+++ b/dev-util/monotone/Manifest
@@ -0,0 +1,3 @@
+MD5 fb68b0fb13f314cc3f58a51804e77dd3 monotone-0.15.ebuild 1096
+MD5 6d796b061ed1c1337ef157a5f74dab35 metadata.xml 403
+MD5 c17be7801cc029d099750d8ddb26d89d files/digest-monotone-0.15 66
diff --git a/dev-util/monotone/files/digest-monotone-0.15 b/dev-util/monotone/files/digest-monotone-0.15
new file mode 100644
index 000000000000..b17fbc878794
--- /dev/null
+++ b/dev-util/monotone/files/digest-monotone-0.15
@@ -0,0 +1 @@
+MD5 6f4378dec56322a82ea37a5b489eb5a0 monotone-0.15.tar.gz 3170364
diff --git a/dev-util/monotone/metadata.xml b/dev-util/monotone/metadata.xml
new file mode 100644
index 000000000000..b9fc2b9c6f11
--- /dev/null
+++ b/dev-util/monotone/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>dragonheart@gentoo.org</email>
+ <name>Daniel Black</name>
+ <description>A user ebuild that I felt obliged to include. Please take over if you want
+it</description>
+</maintainer>
+<longdescription></longdescription>
+</pkgmetadata>
diff --git a/dev-util/monotone/monotone-0.15.ebuild b/dev-util/monotone/monotone-0.15.ebuild
new file mode 100644
index 000000000000..9b2943927f42
--- /dev/null
+++ b/dev-util/monotone/monotone-0.15.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.15.ebuild,v 1.1 2004/12/30 04:35:47 dragonheart Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Monotone Distributed Version Control System"
+HOMEPAGE="http://www.venge.net/monotone/"
+SRC_URI="http://www.venge.net/monotone/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+#Target Keywords ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64"
+
+IUSE="nls"
+# "doc"
+
+RDEPEND="virtual/libc
+ >=dev-libs/boost-1.31.0
+ dev-libs/popt"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-3.3.3
+ sys-devel/gettext"
+# doc? ( dev-lang/perl sys-apps/texinfo )"
+
+src_compile() {
+
+ # more aggressive optimizations cause trouble with the
+ # crypto library
+ # disable stack protector
+
+ replace-flags -O3 -O2
+ append-flags -fno-stack-protector-all -fno-stack-protector
+
+ econf `use_enable nls` || die
+ emake || die "emake failed"
+}
+
+src_test() {
+ einfo "self test currently broken"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+
+ # Generate html docs
+
+ #if use doc ; then
+ # emake html || die "emake html failed"
+ # dohtml -r html/*
+ #fi
+
+ dodoc NEWS
+}