summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-02-06 23:01:54 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-02-06 23:01:54 +0000
commitc150b7b25aac5945e887d32734339c6f72c90216 (patch)
tree1373b7f1575c41ae05c2b1d185a6d17ae0324f8c /dev-util/meld
parentVersion bump. (diff)
downloadgentoo-2-c150b7b25aac5945e887d32734339c6f72c90216.tar.gz
gentoo-2-c150b7b25aac5945e887d32734339c6f72c90216.tar.bz2
gentoo-2-c150b7b25aac5945e887d32734339c6f72c90216.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-util/meld')
-rw-r--r--dev-util/meld/ChangeLog9
-rw-r--r--dev-util/meld/meld-1.8.4.ebuild74
2 files changed, 81 insertions, 2 deletions
diff --git a/dev-util/meld/ChangeLog b/dev-util/meld/ChangeLog
index 416b8c77b36e..ced388b2772c 100644
--- a/dev-util/meld/ChangeLog
+++ b/dev-util/meld/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/meld
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.174 2013/12/08 18:18:33 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.175 2014/02/06 23:01:53 eva Exp $
+
+*meld-1.8.4 (06 Feb 2014)
+
+ 06 Feb 2014; Gilles Dartiguelongue <eva@gentoo.org> +meld-1.8.4.ebuild:
+ Version bump.
08 Dec 2013; Pacho Ramos <pacho@gentoo.org> meld-1.8.2.ebuild:
x86 stable, bug #478252
diff --git a/dev-util/meld/meld-1.8.4.ebuild b/dev-util/meld/meld-1.8.4.ebuild
new file mode 100644
index 000000000000..37b6ae4387bf
--- /dev/null
+++ b/dev-util/meld/meld-1.8.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-1.8.4.ebuild,v 1.1 2014/02/06 23:01:54 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit eutils python-single-r1 gnome2
+
+DESCRIPTION="A graphical diff and merge tool"
+HOMEPAGE="http://meldmerge.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+highlight gnome"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# FIXME: switch gconf-python to python-r1
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.14:2[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.8:2[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ highlight? ( >=dev-python/pygtksourceview-2.10[${PYTHON_USEDEP}] )
+ gnome? ( >=dev-python/gconf-python-2.22:2 )
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ dev-util/gtk-doc-am
+ dev-util/intltool
+"
+
+src_prepare() {
+ # fix the prefix so its not in */local/*
+ sed -e "s:/usr/local:${EPREFIX}/usr:" \
+ -e "s:\$(prefix)/lib:\$(prefix)/$(get_libdir):" \
+ -i INSTALL || die "sed 1 failed"
+
+ # don't install anything to /usr/share/doc/meld
+ sed -e "s:\$(docdir)/meld:\$(docdir)/${PF}:" \
+ -i INSTALL || die "sed 2 failed"
+
+ # don't run scrollkeeper (with the wrong path),
+ # leave that to gnome2.eclass #145833
+ sed -e '/scrollkeeper-update/s/\t/&#/' \
+ -i help/*/Makefile || die "sed 4 failed"
+
+ strip-linguas -i "${S}/po"
+ local mylinguas=""
+ for x in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${x}.po"
+ done
+
+ if [ -n "${mylinguas}" ]; then
+ sed -e "s/PO:=.*/PO:=${mylinguas}/" \
+ -i po/Makefile || die "sed 6 failed"
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ :
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${ED}"/usr/bin
+ doman meld.1
+}