summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-05-09 20:29:02 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-05-09 20:29:02 +0000
commit5068f7bb466c12062c543e67efae9058680236be (patch)
tree4c9272ca0b1032eefaa1339a2a37c032b1481121 /dev-util/mdds
parentfix cpufrequtils-change.sh usage when the default interpreter is not bash, fi... (diff)
downloadgentoo-2-5068f7bb466c12062c543e67efae9058680236be.tar.gz
gentoo-2-5068f7bb466c12062c543e67efae9058680236be.tar.bz2
gentoo-2-5068f7bb466c12062c543e67efae9058680236be.zip
Version bump to 0.8.0, we actually should enforce rebuild of libreoffice when the headers change, because some math operations might get fixed in the bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-util/mdds')
-rw-r--r--dev-util/mdds/ChangeLog8
-rw-r--r--dev-util/mdds/mdds-0.8.0.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-util/mdds/ChangeLog b/dev-util/mdds/ChangeLog
index bd3099b5654a..42ecc3db06c4 100644
--- a/dev-util/mdds/ChangeLog
+++ b/dev-util/mdds/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/mdds
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mdds/ChangeLog,v 1.26 2013/04/27 08:24:58 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mdds/ChangeLog,v 1.27 2013/05/09 20:29:02 scarabeus Exp $
+
+*mdds-0.8.0 (09 May 2013)
+
+ 09 May 2013; Tomáš Chvátal <scarabeus@gentoo.org> +mdds-0.8.0.ebuild:
+ Version bump to 0.8.0, we actually should enforce rebuild of libreoffice when
+ the headers change, because some math operations might get fixed in the bump.
27 Apr 2013; Tomáš Chvátal <scarabeus@gentoo.org> -mdds-0.6.1.ebuild:
Actually binpkg does not need this.
diff --git a/dev-util/mdds/mdds-0.8.0.ebuild b/dev-util/mdds/mdds-0.8.0.ebuild
new file mode 100644
index 000000000000..a44e2c893cd0
--- /dev/null
+++ b/dev-util/mdds/mdds-0.8.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mdds/mdds-0.8.0.ebuild,v 1.1 2013/05/09 20:29:02 scarabeus Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="http://code.google.com/p/multidimalgorithm/"
+SRC_URI="http://multidimalgorithm.googlecode.com/files/${P/-/_}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-libs/boost"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/-/_}
+
+src_configure() {
+ econf \
+ --with-hash-container=boost \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() { :; }
+
+src_test() {
+ tc-export CXX
+ default
+}