summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-03 03:22:06 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-03 03:22:06 +0000
commitf24d6afbe37cf287c5da2665e6ad6cf268ac0698 (patch)
tree24b62f6d9613b74353f47b9f7f9d3e72cfea74ce /dev-util/jam
parentcleanups (diff)
downloadgentoo-2-f24d6afbe37cf287c5da2665e6ad6cf268ac0698.tar.gz
gentoo-2-f24d6afbe37cf287c5da2665e6ad6cf268ac0698.tar.bz2
gentoo-2-f24d6afbe37cf287c5da2665e6ad6cf268ac0698.zip
Make the default C++ compiler c++ instead of cc and add support for .cxx #87974 by Krzysiek Pawlik.
(Portage version: 2.0.51.21)
Diffstat (limited to 'dev-util/jam')
-rw-r--r--dev-util/jam/ChangeLog13
-rw-r--r--dev-util/jam/files/digest-jam-2.5-r11
-rw-r--r--dev-util/jam/files/jam-2.5-cxx.patch43
-rw-r--r--dev-util/jam/jam-2.5-r1.ebuild38
4 files changed, 89 insertions, 6 deletions
diff --git a/dev-util/jam/ChangeLog b/dev-util/jam/ChangeLog
index 36a74c843488..689138d978f7 100644
--- a/dev-util/jam/ChangeLog
+++ b/dev-util/jam/ChangeLog
@@ -1,12 +1,13 @@
# ChangeLog for dev-util/jam
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/jam/ChangeLog,v 1.10 2004/10/16 21:23:27 gongloo Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/jam/ChangeLog,v 1.11 2005/05/03 03:22:06 vapier Exp $
- 16 Oct 2004; <gongloo@gentoo.org> jam-2.5.ebuild:
- Keyworded ~ppc-macos.
+*jam-2.5-r1 (03 May 2005)
- 18 Jul 2004; Daniel Ahlberg <aliz@gentoo.org> jam-2.5.ebuild:
- Added amd64 keyword, closing #57341.
+ 03 May 2005; Mike Frysinger <vapier@gentoo.org> +files/jam-2.5-cxx.patch,
+ +jam-2.5-r1.ebuild:
+ Make the default C++ compiler c++ instead of cc and add support for .cxx
+ #87974 by Krzysiek Pawlik.
01 May 2004; Jeremy Huddleston <eradicator@gentoo.org> jam-2.5.ebuild:
blocking on !dev-util/boost-jam
diff --git a/dev-util/jam/files/digest-jam-2.5-r1 b/dev-util/jam/files/digest-jam-2.5-r1
new file mode 100644
index 000000000000..c6bba9924280
--- /dev/null
+++ b/dev-util/jam/files/digest-jam-2.5-r1
@@ -0,0 +1 @@
+MD5 d340f3c73d16a1206d0e8c88a66428e7 jam-2.5.tar 624640
diff --git a/dev-util/jam/files/jam-2.5-cxx.patch b/dev-util/jam/files/jam-2.5-cxx.patch
new file mode 100644
index 000000000000..4159294d3372
--- /dev/null
+++ b/dev-util/jam/files/jam-2.5-cxx.patch
@@ -0,0 +1,43 @@
+Use the C++ compiler to build C++ code by default.
+
+Patch by Krzysiek Pawlik
+http://bugs.gentoo.org/show_bug.cgi?id=87974
+
+--- jam-2.5/Jambase
++++ jam-2.5/Jambase
+@@ -533,7 +533,7 @@
+ ASFLAGS ?= ;
+ AWK ?= awk ;
+ BINDIR ?= /usr/local/bin ;
+- C++ ?= cc ;
++ C++ ?= c++ ;
+ C++FLAGS ?= ;
+ CC ?= cc ;
+ CCFLAGS ?= ;
+@@ -1070,6 +1070,7 @@
+ case .C : C++ $(<) : $(>) ;
+ case .cc : C++ $(<) : $(>) ;
+ case .cpp : C++ $(<) : $(>) ;
++ case .cxx : C++ $(<) : $(>) ;
+ case .f : Fortran $(<) : $(>) ;
+ case .l : Cc $(<) : $(<:S=.c) ;
+ Lex $(<:S=.c) : $(>) ;
+--- jam-2.5/jambase.c
++++ jam-2.5/jambase.c
+@@ -325,7 +325,7 @@
+ "ASFLAGS ?= ;\n",
+ "AWK ?= awk ;\n",
+ "BINDIR ?= /usr/local/bin ;\n",
+-"C++ ?= cc ;\n",
++"C++ ?= c++ ;\n",
+ "C++FLAGS ?= ;\n",
+ "CC ?= cc ;\n",
+ "CCFLAGS ?= ;\n",
+@@ -658,6 +658,7 @@
+ "case .C : C++ $(<) : $(>) ;\n",
+ "case .cc : C++ $(<) : $(>) ;\n",
+ "case .cpp : C++ $(<) : $(>) ;\n",
++"case .cxx : C++ $(<) : $(>) ;\n",
+ "case .f : Fortran $(<) : $(>) ;\n",
+ "case .l : Cc $(<) : $(<:S=.c) ;\n",
+ "Lex $(<:S=.c) : $(>) ;\n",
diff --git a/dev-util/jam/jam-2.5-r1.ebuild b/dev-util/jam/jam-2.5-r1.ebuild
new file mode 100644
index 000000000000..64d9eb6f5338
--- /dev/null
+++ b/dev-util/jam/jam-2.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/jam/jam-2.5-r1.ebuild,v 1.1 2005/05/03 03:22:06 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Just Another Make - advanced make replacement"
+HOMEPAGE="http://www.perforce.com/jam/jam.html"
+SRC_URI="ftp://ftp.perforce.com/pub/jam/${P}.tar"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
+IUSE=""
+
+DEPEND="sys-devel/bison
+ !dev-util/boost-jam"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-cxx.patch
+}
+
+src_compile() {
+ # The bootstrap makefile assumes ${S} is in the path
+ env PATH="${PATH}:${S}" \
+ emake -j1 \
+ YACC="bison -y" \
+ CFLAGS="${CFLAGS}" \
+ || die
+}
+
+src_install() {
+ BINDIR="${D}/usr/bin" ./jam0 install || die
+ dohtml Jam.html Jambase.html Jamfile.html
+ dodoc README RELNOTES Porting
+}