summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2009-09-17 17:39:58 +0000
committerDror Levin <spatz@gentoo.org>2009-09-17 17:39:58 +0000
commit1d061435c10591bc1f8a28e7c12ac88efcc2861c (patch)
treefd838348b6dc0f2910b730aa27090ac8ae686643 /dev-util/hgview
parentStable for HPPA (bug #283969). (diff)
downloadgentoo-2-1d061435c10591bc1f8a28e7c12ac88efcc2861c.tar.gz
gentoo-2-1d061435c10591bc1f8a28e7c12ac88efcc2861c.tar.bz2
gentoo-2-1d061435c10591bc1f8a28e7c12ac88efcc2861c.zip
Version bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/hgview')
-rw-r--r--dev-util/hgview/ChangeLog7
-rw-r--r--dev-util/hgview/hgview-1.0.1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-util/hgview/ChangeLog b/dev-util/hgview/ChangeLog
index b5c6f329859d..8ff29be63fec 100644
--- a/dev-util/hgview/ChangeLog
+++ b/dev-util/hgview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/hgview
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/hgview/ChangeLog,v 1.1 2009/07/23 22:48:37 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/hgview/ChangeLog,v 1.2 2009/09/17 17:39:58 spatz Exp $
+
+*hgview-1.0.1 (17 Sep 2009)
+
+ 17 Sep 2009; Dror Levin <spatz@gentoo.org> +hgview-1.0.1.ebuild:
+ Version bump, bug 283709.
*hgview-1.0.0 (23 Jul 2009)
diff --git a/dev-util/hgview/hgview-1.0.1.ebuild b/dev-util/hgview/hgview-1.0.1.ebuild
new file mode 100644
index 000000000000..ec551b9c9037
--- /dev/null
+++ b/dev-util/hgview/hgview-1.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/hgview/hgview-1.0.1.ebuild,v 1.1 2009/09/17 17:39:58 spatz Exp $
+
+EAPI="2"
+
+inherit distutils
+
+DESCRIPTION="PyQt4 based Mercurial log navigator"
+HOMEPAGE="http://www.logilab.org/project/name/hgview"
+SRC_URI="http://ftp.logilab.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/egenix-mx-base
+ dev-python/PyQt4[X]
+ dev-python/qscintilla-python"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # fix mercurial extension install path
+ local origdir="share/python-support/mercurial-common/hgext"
+ local sitedir="$(python_get_sitedir)/hgext"
+ sed -i -e "s:${origdir}:${sitedir#/usr/}:" \
+ "${S}/hgviewlib/__pkginfo__.py" || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ # install the mercurial extension config
+ insinto /etc/mercurial/hgrc.d || die
+ doins hgext/hgview.rc || die
+}