summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-09-06 21:28:40 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-09-06 21:28:40 +0000
commitca068075cd43594f3fdfa3466f3dbabc791f62de (patch)
tree09b92bc65a1bfc7cd015b291a24542c3637f91a4 /dev-util/guile
parentclosing bug #23493 (GUILE_LOAD_PATH in env now) (diff)
downloadgentoo-2-ca068075cd43594f3fdfa3466f3dbabc791f62de.tar.gz
gentoo-2-ca068075cd43594f3fdfa3466f3dbabc791f62de.tar.bz2
gentoo-2-ca068075cd43594f3fdfa3466f3dbabc791f62de.zip
closing bug #23493 (GUILE_LOAD_PATH in env now)
Diffstat (limited to 'dev-util/guile')
-rw-r--r--dev-util/guile/ChangeLog13
-rw-r--r--dev-util/guile/Manifest4
-rw-r--r--dev-util/guile/files/digest-guile-1.6.4-r11
-rw-r--r--dev-util/guile/guile-1.6.4-r1.ebuild47
4 files changed, 60 insertions, 5 deletions
diff --git a/dev-util/guile/ChangeLog b/dev-util/guile/ChangeLog
index 12bc05ec5da0..ddc64b1676d7 100644
--- a/dev-util/guile/ChangeLog
+++ b/dev-util/guile/ChangeLog
@@ -1,9 +1,16 @@
# ChangeLog for dev-util/guile
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/ChangeLog,v 1.18 2003/08/24 13:01:23 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/ChangeLog,v 1.19 2003/09/06 21:28:37 drobbins Exp $
- 19 Aug 2003; Aron Griffis <agriffis@gentoo.org> guile-1.6.4.ebuild:
- Fix bug 26484 by filtering out -g3
+*guile-1.6.4-r1 (06 Sep 2003)
+
+ 06 Sep 2003; Daniel Robbins <drobbins@gentoo.org> guile-1.6.4-r1.ebuild: new
+ revision to close bug 23493; texmacs should now be able to find guile via the
+ GUILE_LOAD_PATH env var (/etc/env.d fix.) This shouldn't break any arch so
+ keeping the KEYWORDS the same on this bump.
+
+ 19 Aug 2003; Aron Griffis <agriffis@gentoo.org> guile-1.6.4.ebuild: Fix bug
+ 26484 by filtering out -g3
24 Jul 2003; Tavis Ormandy <taviso@gentoo.org> guile-1.6.4.ebuild:
~alpha
diff --git a/dev-util/guile/Manifest b/dev-util/guile/Manifest
index 50caf1b3172e..f92194f53745 100644
--- a/dev-util/guile/Manifest
+++ b/dev-util/guile/Manifest
@@ -1,7 +1,7 @@
MD5 63bed0a2d5349819dcea648aa7bce846 guile-1.4-r3.ebuild 739
MD5 215da61a38ad9d107418d0ed51b57b8a guile-1.4.1.ebuild 889
-MD5 3d606e68ae82711843b4cd42c46af7d3 guile-1.6.4-r1.ebuild 1288
-MD5 a5060419e5d96690dd714621b9f47c76 ChangeLog 2288
+MD5 cad638bc4cc84d2ea0d54e76c86eeb9d guile-1.6.4-r1.ebuild 1487
+MD5 39dcb8d4cceccd15826b98f8cf977c38 ChangeLog 2606
MD5 4e5c02b73517c1f5fa9a644ba3fc62a1 guile-1.6.4.ebuild 1131
MD5 c6e6b728591d901172031cc9a0997d31 files/digest-guile-1.4.1 64
MD5 c8ef00401b82bbfae1fa78785341e8dc files/digest-guile-1.6.4 64
diff --git a/dev-util/guile/files/digest-guile-1.6.4-r1 b/dev-util/guile/files/digest-guile-1.6.4-r1
new file mode 100644
index 000000000000..38ecb5be9df7
--- /dev/null
+++ b/dev-util/guile/files/digest-guile-1.6.4-r1
@@ -0,0 +1 @@
+MD5 a4aceb5f185878c1de4e8aa7c38b6d1d guile-1.6.4.tar.gz 2778075
diff --git a/dev-util/guile/guile-1.6.4-r1.ebuild b/dev-util/guile/guile-1.6.4-r1.ebuild
new file mode 100644
index 000000000000..02a11ce2f419
--- /dev/null
+++ b/dev-util/guile/guile-1.6.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.6.4-r1.ebuild,v 1.1 2003/09/06 21:28:37 drobbins Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Scheme interpreter"
+SRC_URI="mirror://gnu/guile/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/guile/"
+
+IUSE=""
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~alpha hppa"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.1"
+
+# NOTE: in README-PACKAGERS, guile recommends different versions be installed
+# in parallel. They're talking about LIBRARY MAJOR versions and not
+# the actual guile version that was used in the past.
+#
+# So I'm slotting this as 12 beacuse of the library major version
+
+SLOT="12"
+MAJOR="1.6"
+
+src_compile() {
+ # Fix for bug 26484: This package fails to build when built with
+ # -g3, at least on some architectures. (19 Aug 2003 agriffis)
+ filter-flags -g3
+
+ econf \
+ --with-threads \
+ --with-modules || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS
+ #texmacs needs this, closing bug #23493
+ dodir /etc/env.d
+ #We don't slot the env.d entry because /usr/bin/guile-config is there anyway,
+ #and will only match the last guile installed. so the GUILE_LOAD_PATH will
+ #match the data available from guile-config.
+ echo "GUILE_LOAD_PATH=\"/usr/share/guile/${MAJOR}\"" > ${D}/etc/env.d/50guile
+}