summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 12:45:09 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 12:45:09 +0000
commite27c43913c049681679b773f3dbb34ab43f6e209 (patch)
tree6667392b7a863994137178138537c6472535fa94 /dev-util/gob
parentnew version .. no RC5, sorry (diff)
downloadgentoo-2-e27c43913c049681679b773f3dbb34ab43f6e209.tar.gz
gentoo-2-e27c43913c049681679b773f3dbb34ab43f6e209.tar.bz2
gentoo-2-e27c43913c049681679b773f3dbb34ab43f6e209.zip
A=-fix, try->die, tab-fixes, stylefixes, ...
Diffstat (limited to 'dev-util/gob')
-rw-r--r--dev-util/gob/gob-1.0.9.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/dev-util/gob/gob-1.0.9.ebuild b/dev-util/gob/gob-1.0.9.ebuild
index 5d1047a02776..980dc8116f1b 100644
--- a/dev-util/gob/gob-1.0.9.ebuild
+++ b/dev-util/gob/gob-1.0.9.ebuild
@@ -1,27 +1,29 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gob/gob-1.0.9.ebuild,v 1.2 2001/06/24 02:20:30 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gob/gob-1.0.9.ebuild,v 1.3 2001/11/10 12:45:09 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="GOB is a preprocessor for making GTK+ objects with inline C code"
-SRC_URI="http://ftp.5z.com/pub/gob/${A}"
+SRC_URI="http://ftp.5z.com/pub/gob/${P}.tar.gz"
HOMEPAGE="http://www.5z.com/jirka/gob.html"
-DEPEND=">=dev-libs/glib-1.2.10 sys-devel/flex"
RDEPEND=">=dev-libs/glib-1.2.10"
-src_compile() {
- try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST}
- try make
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ assert
+ make || die
}
src_install () {
+ make DESTDIR=${D} install || die
- try make DESTDIR=${D} install
- dodoc AUTHORS COPYING ChangeLog NEWS README TODO
-
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
}
-