summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-08-09 21:44:12 +0000
committerMichael Januszewski <spock@gentoo.org>2005-08-09 21:44:12 +0000
commit8b715f05fda15b4da79f806c739764de38a37751 (patch)
treef428b1ece6b946147dfd4f61f62d81695c2d364f /dev-util/git
parentstable on alpha (diff)
downloadgentoo-2-8b715f05fda15b4da79f806c739764de38a37751.tar.gz
gentoo-2-8b715f05fda15b4da79f806c739764de38a37751.tar.bz2
gentoo-2-8b715f05fda15b4da79f806c739764de38a37751.zip
Version bump.
(Portage version: 1.589-cvs)
Diffstat (limited to 'dev-util/git')
-rw-r--r--dev-util/git/ChangeLog7
-rw-r--r--dev-util/git/files/digest-git-0.99.31
-rw-r--r--dev-util/git/git-0.99.3.ebuild40
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 20024455cffa..4e2d36bb6ed3 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.10 2005/07/15 17:28:18 r3pek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.11 2005/08/09 21:44:12 spock Exp $
+
+*git-0.99.3 (09 Aug 2005)
+
+ 09 Aug 2005; Michał Januszewski <spock@gentoo.org> +git-0.99.3.ebuild:
+ Version bump.
15 Jul 2005; Carlos Silva <r3pek@gentoo.org> git-0.7.ebuild:
Closing bug #98032. thx Carsten Lohrke
diff --git a/dev-util/git/files/digest-git-0.99.3 b/dev-util/git/files/digest-git-0.99.3
new file mode 100644
index 000000000000..75463bbe00ed
--- /dev/null
+++ b/dev-util/git/files/digest-git-0.99.3
@@ -0,0 +1 @@
+MD5 a87a4a0ce8ed6907f5b15e1f658fb3b2 git-0.99.3.tar.bz2 264360
diff --git a/dev-util/git/git-0.99.3.ebuild b/dev-util/git/git-0.99.3.ebuild
new file mode 100644
index 000000000000..705ffa760fd7
--- /dev/null
+++ b/dev-util/git/git-0.99.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-0.99.3.ebuild,v 1.1 2005/08/09 21:44:12 spock Exp $
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="http://kernel.org/pub/software/scm/git/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+IUSE="mozsha1 ppcsha1"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ net-misc/curl
+ !app-misc/git"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:-g -O2:${CFLAGS}:" \
+ Makefile
+}
+
+src_compile() {
+ if use mozsha1; then
+ export MOZILLA_SHA1=yes
+ elif use ppcsha1; then
+ export PPC_SHA1=yes
+ fi
+
+ make prefix=/usr || die "make failed"
+}
+
+src_install() {
+ make dest=${D} prefix=/usr install || die "make install failed"
+ dodoc README
+}