summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-06 21:06:29 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-06 21:06:29 +0000
commitf794bf911a82f5905cac910efbb59bd4548242cd (patch)
tree03c0ce5ca23ffcd711f974fc86c867963b5e3d8e /dev-util/fhist
parentMarking enthoughtbase-3.0.6 ~ppc for bug 341627 (diff)
downloadgentoo-2-f794bf911a82f5905cac910efbb59bd4548242cd.tar.gz
gentoo-2-f794bf911a82f5905cac910efbb59bd4548242cd.tar.bz2
gentoo-2-f794bf911a82f5905cac910efbb59bd4548242cd.zip
Version Bump, Dropped arches because of missing dep, added amd64
(Portage version: 2.2.0_alpha13/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/fhist')
-rw-r--r--dev-util/fhist/ChangeLog10
-rw-r--r--dev-util/fhist/fhist-1.19.ebuild35
-rw-r--r--dev-util/fhist/files/1.19-ldflags.patch43
3 files changed, 86 insertions, 2 deletions
diff --git a/dev-util/fhist/ChangeLog b/dev-util/fhist/ChangeLog
index 0eddfee352c2..229b2dacf4ce 100644
--- a/dev-util/fhist/ChangeLog
+++ b/dev-util/fhist/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/fhist
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/fhist/ChangeLog,v 1.20 2009/12/04 21:57:41 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/fhist/ChangeLog,v 1.21 2011/01/06 21:06:29 jlec Exp $
+
+*fhist-1.19 (06 Jan 2011)
+
+ 06 Jan 2011; Justin Lecher <jlec@gentoo.org> +files/1.19-ldflags.patch,
+ +fhist-1.19.ebuild:
+ Version Bump, Dropped arches because of missing dep, added amd64
04 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org> fhist-1.16.ebuild:
Use -j1 for test and install as well as build, bug #295744.
diff --git a/dev-util/fhist/fhist-1.19.ebuild b/dev-util/fhist/fhist-1.19.ebuild
new file mode 100644
index 000000000000..470258960b6b
--- /dev/null
+++ b/dev-util/fhist/fhist-1.19.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/fhist/fhist-1.19.ebuild,v 1.1 2011/01/06 21:06:29 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="File history and comparison tools"
+HOMEPAGE="http://fhist.sourceforge.net/fhist.html"
+SRC_URI="http://fhist.sourceforge.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libexplain
+ sys-devel/gettext
+ sys-apps/groff"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ test? ( app-arch/sharutils )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+}
+
+src_install () {
+ emake -j1 DESTDIR="${D}" \
+ install || die "make install failed"
+
+ dodoc README || die
+}
diff --git a/dev-util/fhist/files/1.19-ldflags.patch b/dev-util/fhist/files/1.19-ldflags.patch
new file mode 100644
index 000000000000..c0fa0e825a9e
--- /dev/null
+++ b/dev-util/fhist/files/1.19-ldflags.patch
@@ -0,0 +1,43 @@
+diff --git a/Makefile.in b/Makefile.in
+index 8aa8408..2c39b28 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -500,8 +500,9 @@ common/sub/expr.$(OBJEXT): common/sub/expr.c common/ac/stdarg.h \
+ $(CC) $(CPPFLAGS) $(CFLAGS) -I. -c common/sub/expr.c
+ mv expr.$(OBJEXT) common/sub/expr.$(OBJEXT)
+
+-common/sub/expr_gram.yacc.c common/sub/expr_gram.yacc.h: \
+- common/sub/expr_gram.y
++common/sub/expr_gram.yacc.c: common/sub/expr_gram.yacc.h
++
++common/sub/expr_gram.yacc.h: common/sub/expr_gram.y
+ $(YACC) -d common/sub/expr_gram.y
+ sed -e 's/[yY][yY]/sub_expr_gram_/g' y.tab.c > \
+ common/sub/expr_gram.yacc.c
+@@ -961,7 +962,7 @@ common/libcommon.a: $(lib_obj)
+ fcomp_obj = fcomp/main.$(OBJEXT)
+
+ bin/fcomp$(EXEEXT): $(fcomp_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fcomp_obj) \
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fcomp_obj) \
+ common/libcommon.a $(LIBS)
+
+ $(bindir)/fcomp$(EXEEXT): bin/fcomp$(EXEEXT) .bindir
+@@ -974,7 +975,7 @@ fhist_obj = fhist/breaks.$(OBJEXT) fhist/diff.$(OBJEXT) \
+ fhist/subroutine.$(OBJEXT) fhist/update.$(OBJEXT)
+
+ bin/fhist$(EXEEXT): $(fhist_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fhist_obj) \
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fhist_obj) \
+ common/libcommon.a $(LIBS)
+
+ $(bindir)/fhist$(EXEEXT): bin/fhist$(EXEEXT) .bindir
+@@ -983,7 +984,7 @@ $(bindir)/fhist$(EXEEXT): bin/fhist$(EXEEXT) .bindir
+ fmerge_obj = fmerge/main.$(OBJEXT) fmerge/work.$(OBJEXT)
+
+ bin/fmerge$(EXEEXT): $(fmerge_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fmerge_obj) \
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fmerge_obj) \
+ common/libcommon.a $(LIBS)
+
+ $(bindir)/fmerge$(EXEEXT): bin/fmerge$(EXEEXT) .bindir