summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-20 06:26:00 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-20 06:26:00 +0000
commitcf8363e588f5bd244cf86bb8fc95d6238d129376 (patch)
tree52ea4757e43f79b10d8116fec1996639b197751c /dev-util/cscope
parenttypo fix (diff)
downloadgentoo-2-cf8363e588f5bd244cf86bb8fc95d6238d129376.tar.gz
gentoo-2-cf8363e588f5bd244cf86bb8fc95d6238d129376.tar.bz2
gentoo-2-cf8363e588f5bd244cf86bb8fc95d6238d129376.zip
bison fix
Diffstat (limited to 'dev-util/cscope')
-rw-r--r--dev-util/cscope/Manifest6
-rw-r--r--dev-util/cscope/cscope-15.3.ebuild7
-rw-r--r--dev-util/cscope/cscope-15.4.ebuild7
3 files changed, 15 insertions, 5 deletions
diff --git a/dev-util/cscope/Manifest b/dev-util/cscope/Manifest
index f018588ab0e3..7f782a094666 100644
--- a/dev-util/cscope/Manifest
+++ b/dev-util/cscope/Manifest
@@ -1,6 +1,6 @@
-MD5 720d414a79e2fbc262054bb5c5cab5b8 ChangeLog 1328
-MD5 5c755a741ccd9fbab35f29da3f88b1b8 cscope-15.3.ebuild 743
-MD5 59ae8bba280163dbb62dd97d219bc3be cscope-15.4.ebuild 1139
+MD5 6f3e182d706cb2d5596330a3d76516d7 cscope-15.4.ebuild 1209
+MD5 ab697301061460c3152e669ce1307c73 cscope-15.3.ebuild 816
+MD5 dfab885aabaf563124e7756c48b28f8c ChangeLog 1624
MD5 28ddc553966bf7045758be324600f5c8 files/50xcscope-gentoo.el 95
MD5 326b4f2785a741e10f370a6accfd1c28 files/digest-cscope-15.3 63
MD5 ae33cee910261c162094e95a82523f6c files/digest-cscope-15.4 63
diff --git a/dev-util/cscope/cscope-15.3.ebuild b/dev-util/cscope/cscope-15.3.ebuild
index 6a289f3a9451..6c9012b35f3d 100644
--- a/dev-util/cscope/cscope-15.3.ebuild
+++ b/dev-util/cscope/cscope-15.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.3.ebuild,v 1.22 2003/09/19 01:00:44 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.3.ebuild,v 1.23 2003/09/20 06:25:58 seemant Exp $
inherit gnuconfig
@@ -15,10 +15,15 @@ KEYWORDS="x86 ppc sparc alpha hppa mips arm amd64 ia64"
RDEPEND=">=sys-libs/ncurses-5.2"
DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ sys-devel/bison
sys-devel/flex"
src_compile() {
gnuconfig_update
+
+ sed -i -e "s:={:{:" src/egrep.y
+
econf || die
make clean || die
emake || die
diff --git a/dev-util/cscope/cscope-15.4.ebuild b/dev-util/cscope/cscope-15.4.ebuild
index fc35bef7422b..6fd526d32ad9 100644
--- a/dev-util/cscope/cscope-15.4.ebuild
+++ b/dev-util/cscope/cscope-15.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.4.ebuild,v 1.5 2003/09/06 20:28:40 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.4.ebuild,v 1.6 2003/09/20 06:25:58 seemant Exp $
inherit elisp gnuconfig
@@ -15,13 +15,18 @@ KEYWORDS="-x86 -ppc -sparc -alpha -hppa -mips -arm"
RDEPEND=">=sys-libs/ncurses-5.2"
DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
sys-devel/flex
+ sys-devel/bison
emacs? ( virtual/emacs )"
SITEFILE=50xcscope-gentoo.el
src_compile() {
gnuconfig_update
+
+ sed -i -e "s:={:{:" src/egrep.y
+
econf || die
make clean || die
emake || die